Orchestrator: Type into with wrong directory separator in path name


I have added a job with a daily trigger in Orchestrator.

The job should do the following:

Open SAP SRM in browser.
Export a file from SAP SRM.
Save the file in *.xlsb format in a folder.

The job is running fine but when I get to the step, where the file should be saved. Then the directory separator () in the variable ‘Path’ is replaced by (<) and the file cannot be saved.

So instead of this path:
P:\CØK\Lukkede Mapper\Indkobsafdelingen\SUPPORT OG ANALYSE\A&U\POWL eksporter\

I get this path:

"P:<CØK<Lukkede Mapper<Indkobsafdelingen<SUPPORT OG ANALYSE<A&U<POWL eksporter<

How can I solve this problem? The workflow is running fine in Studio.

Best regards

(1) Try double slash \ instead of single slash \

(2) Set clipboard text as the filename and paste it in instead of using type


Hi @morruu,

If it’s a dynamically created directory, use Path.Combine() snippet. else you can replace the < by using String Replace Operation.


Thank you for your reply. I solved it by using Anders solution.

Thank you for pointing me in the right direction.

I solved it with these activities.

This might be caused by a different keyboard config in your server, better to look at that than rework all your processes…