Orchestrator timing out when I am not logged into windows user on unattended launch

I have a process that worked fine before I had to reinstall windows and uipath, now when the robot launches (completed fresh environments) the processes seem to complete just fine (meaning I am seeing the expected business process results when run in attended) but orchestrator is returning this error when remote in the logs and I cannot figure out what it is…
My machine is a windows 10 machine (not server) and I have a seperate windows login just for “Robot”

when I run debug everything works flawlessly

*Also I verified the screen size settings in robot match that of the environment

I was able to get the robot to get past the first time out by implementing a kill window but it fails on the vey next activity with the exact same issue.

Timeout reached.

at UiPath.Core.Activities.ObsoleteTaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
— End of stack trace from previous location where exception was thrown —
at UiPath.UIAutomationNext.Activities.NApplicationCard.OnFault(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Xaml attached
Main.xaml (109.7 KB)

Please check this documentation Windows Sessions and observe the limitations for a Windows Workstation (WIndows 10 in your case).

The robot is already setup to login to console

According to this article it should with or without login to console selected… sorry but this is not really helpful.

After trying the alternative login to console methods orchestrator throws this error when trying to start this process

I don’t understand why it would work before I reinstalled windows and UiPath and now it does not, the orchestrator settings should be fine since it worked before

In Windows 10 only one user can use the session. So, if you have multiple users that didn’t disconnect, this is an issue. If you have an unattended robot, better open a cmd.exe and type logoff in order to Log out from the session.

Also, if you are using a custom resolution for the robot, the login To Console should be Enabled and set to False.

Check the prerequisites for installing the robot here Installing the Robot

Check the frequently encountered errors here: Frequently Encountered Orchestrator Errors

I made sure all users were logged off before executing the unattended robot. I command would not work in the code because the robot can’t communicate to issue the command…