Orchestrator showing unlicensed Robot

Hey community,

So i’m facing an issue that appears to be common, my connection to the orchestrator is unlicensed.
I think i did everything correct as i am showing to you in the screenshots bellow.
I have also researched similar topics and followed the recommended steps but it’s still not working.
Could the problem be from my windows?


Thanks,

@Gaki On the first look it seems to me that your Robot in not associated with the Machine in the orchestrator

Hi @Gaki

Agree with @ppr. I also noticed that you have not connected it with an environment as well.

So link the robot to an environment and also with the machine you just created in the orchestrator…

It’ll work .

yes, u are right. but when i try to connect my floating robot to the template machine, it doesnt find it. why is that?

i did. it doesnt.
i also provisioned another standard robot that is connected to the standard machine and also the enviroment. same issue, connected, unlicensed.

what can be the issue? versions? i dont understand…

can you please post a screenshot from the Licence settings, thanks

HI @Gaki

Your machine name is not right… It should have the same machine name shown in the Robot Tray.

1 Like

u re right, i missed that.
i corrected. still failed to connect.

it appears my standard robot has eventually connected and is licensed. thanks.

but what about the floating robots? why cant i connect them to their matching machines?

1 Like

Sometimes a restart from Robotservices /.exe helped after editing the setting. Give a try?

Similar to that, the floating robots also should work… try what was suggested by @ppr and see whether it works…

1 Like

how do i do that?

Simplest way is restarting the machine
Or
Via Taskmanager
grafik

2 Likes

i restarted the process. my floating robot still wont connect to the template machine :frowning: this is becoming frustrating :rofl: thank you again for your patience and support :pray:
any other suggestions?

Now it becomes tricky to guide you from remote.
Maybe you consequently check following

  • the WindowsAuth.Enabled parameter from the web.config file has to be set to true ;
  • the WindowsAuth.Domain parameter has to be set to a valid domain;
  • the Robot machines you want to deploy have to be in the Active Directory domain that was specified in the WindowsAuth.Domain parameter;
  • Orchestrator and the Robots need to be part of the same Active Directory domain.

Would it be an option to delete and recreate the floating BOT?

Yes, it really is tricky, i found lots of web.config files. Which should be checked/modified? The most recent one?
Also, when searching for the WindowsAuth. parameters i can only find 2 that dont really match (ps below)
Regarding to Active Directory, i’m using a personal pc, i don’t think that’s registered with an AD.
I deleted and recreated the floating bot lots of times before, still didnt work.
Thanks,