Orchestrator Process Parameters not passing to attended robot

Hi again,

So we finally got our orchestrator license and a few attended (concurrent uers) and developer robots.
I’ve created a process and added it to my development environment. When I created the process I set the parameter for an argument in the process, but when I run it on the developer from the UiRobot Tray, the parameter isn’t used. Have not tried the Attended robot yet. I see that if you launch the robot using jobs in orchestrator is says it will inherit from process, but why does the Robot Tray not inherit from process. As I only have attended licenses I cannot use the Jobs option in orchestrator to start processes. If I launch it from the tray I have no option to set the argument as a normal user (attended) so it should inherit from the process configuration in orchestrator, right? At least that was what I expected as I don’t expect the employees that use these robots to know what the arguments should be.

I followed the information from these two links
https://orchestrator.uipath.com/v2018.3/docs/about-input-and-output-parameters

https://orchestrator.uipath.com/v2018.3/docs/example-of-using-input-and-output-parameters

A blank process to show a message box
1

Published to Orchestrator and parameter for message box set
2

Running said process on development system throught Tray but it does not use the parameter set in orchestrator
3

2019-01-24%2016_16_42-Jobs%20-%20UiPath%20Orchestrator%20-%20Internet%20Explorer

1 Like

Hi @Rasmus_J

This feature will be improved in the future. Current behaviour is indeed restricted and does not allow for the robots launched from tray to inherit parameters from Orchestrator. In this case, the default value set in Studio is used.

If you could elaborate on your potential use case, we might be able to suggest a workaround. The most common choice would be to allow the attended user to make a choice based on an input box, custom input form or a simple Excel configuration file.

Hi @loginerror

The use case is that we have multiple departments that use the same program does that exact same steps but with different names for some of the steps in the program.

So instead of letting the user input data that is static in the program but changes depending on what department the user is in, I would like to reuse the package and deploy it as a process for the different environments I’ve set up for each department. This way I only need to upload and maintain a single package for all attended users for all the different environments and it will save a lot of time. I could do a domain lookup on the user to determine where the user belong, but some users can have both defining roles, so that would not work.

For now the solution would be setting the default value for the package and upload 3 identical packages for the 3 different environments with different default values (including when maintaining the package). This is in no way optimal and should be fixed, no doubt about that, but for now I don’t see any other way, simply because attended robots don’t read the variables from orchestrator that have been set when you create the process :face_with_raised_eyebrow::thinking:

1 Like

I spoke a bit with our product team and further improvements in this area (mainly Robot Agent) are coming later this year.

For now, you will indeed have to use some workarounds. Depending on your setup, I can think of one more possible workaround. You could have a config file within your project that would get Published together with the project. It could bind the user name with the parameters locally.

@loginerror,

What is the expected timing on a fix for this or has it already been fixed in one of the releases this year? We are on 2018.4.5 and are experiencing this issue. We pass in a parameter for email addresses that we send messages to from the bot over SMTP.

Thanks.

Well it’s not fixed in the latest Community edition as my short term intern just tested it. So that’s a bummer :frowning: So not expecting this to be fixed in the rollout of 2019 enterprise that we will get in the upcoming month. I understand I can do config file but I would still need to add the same robot 3 times to get 3 different configs and then push them to each group of PCs and i would have 3 processes to update at a time instead of just one process that I can push to different groups with different parameters. I can’t see why this isn’t implemented yet. It sounds like a small thing but it has so much impact on daily work that the parameters is only used when run from Orchestrator, and not used when run from the agent in tray on attended or dev license. God this is so frustrating! :triumph:

1 Like

I am waiting for this problem to be solved too!
UiPath, please fix this as soon as possible.
Config file is really not a satisfying option for this, why would we duplicate multiple times the same process, who’s going to maintain that ?!

2 Likes

Count me in on this one. I’d like to be able to add the in-params when I start the process from the robot tray.

This is a horrible, horrible thing to leave undone. It’s a hidden bear trap that you can only find if you step on it.
Also, makes development/debugging slower. Fix this soon.

1 Like

Hi guys! This was in the plan for the first version of Agent Desktop (the replacement of Robot Tray) but unfortunately, we had some execution problems and we managed to release it later than expected and with a bit less functionality.
Nevertheless, we will continue to work on it and make it the new face of Attended Automation and process I/O is one of our top priorities. I don’t want to provide a timeline for it (look what happened when we did :slight_smile: ) but I expect it to be one of the next features coming in Agent Desktop.
Thanks for your understanding and sorry for the delay of this feature.

PS: If you guys have any other ideas regarding Agent Desktop, please add them here: Agent Desktop - Ideas needed - #68 by vasanth8891

3 Likes

Hi @radutzp and @loginerror, has this feature been added yet or is it in the pipeline? I tried it today and I do not think that this feature is live yet.

I think the Attended robot still does not take the input parameter from Orchestrator.

First thing to note here is that running attended processes from Orchestrator in not supported, these can only be deployed on the attended machines for users to run them.

As to the feature of passing some input arguments, these was added in the 20.8 Community Release :), see here:

(it’s a direct link to the interesting part)

1 Like

3 posts were split to a new topic: Orchestrator parameters do not work with UiPath Assistant