Orchestrator Problem - Login To Console


#1

Hello

I have a problem related to Orchestrator I’d like to comment in case someone faced an issue like this…

The software is a java application that we launch via bat file. After some seconds a popup appears, we type login user, click Connect, a second popup appears, select a combobox and click Connect again. After that we access a browser embedded and start working.

When we are logged in in the server via remote desktop and we launch the robot manually in uipath, it works fine.

When we publish the robot and launch it starting a new job in the orchestrator, we get timeouts when trying to identify some elements.

We added high delays but the problem is not solved. It’s like the proccess of launching a java app is much slower via orchestrator…or perhaps is a configuration problem, I don’t know…

I know is rather vague the problem, but perhaps someone can tell me some detail I’m missing or an idea about why the time of execution is so different between running the robot in the server and using the orchestrator…

Thank you


Cannot able to login in orchestrator
#2

Could you try to take a screenshot on the exception branch when started from Orchestrator?


#3

Mmm, I just can write the exception messages that we got, it’s always a timeout waiting an element to appear…

message : "Invoke TF7_Abrir workflow: On Login Appear : Activity timeout exceeded"
message : "Invoke TF7_Abrir workflow: On TF7 Appear : Activity timeout exceeded"
message : “Invoke TF7_Abrir workflow: On Sing in IMS Appear : Activity timeout exceeded”

Process : CAIXA_VPO_BK_PILOTO
Package : CAIXA_VPO
Robot : RBTCBK_PILOTO
Info : "Execution error : UiPath.Core.Activities.ActivityTimeoutException: Activity timeout exceeded\r\n at UiPath.Core.Activities.InvokeWorkflowFile.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)\r\n at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)\r\n at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)"
Start Time : "2017-06-22T10:01:10.983Z"
End Time : “2017-06-22T10:04:28.183Z”

We don’t have this timeout problems launching from uipath

Thank you


#4

I want to add that we have two other robots, one launch a webbrowser and the other an ibm terminal, and in both we don’t have this problem, we can launch them from uipath or from orchestrator with no big speed difference…


#5

Well…connect to that machine and start the process from Orchestrator. Does it work?

You should connect via the same method that is saved in appsettings:

  • if you connect via RDP you should have loginToConsole: false
  • if you connect directly you should have loginToConsole: true
    Use same credentials when you login that are saved in Orchestrator.

Screenshot may help as you/robot may encounter some resolution issues.


#6

Hum, where can I check this loginToConsole flag, please?

Thank you for your time


#7

Hi @Pablo,
You can Navigate to the following file: C:\ProgramData\UiPath\Uipath.settings
In that Settings file one property you have that is : Login to Console.
Regards,
Jiban


#8

Hi @badita,
I observed one thing that in my *C:\ProgramData\UiPath* directory i dont have that file.
I dont know why and how i am missing that settings file.
Can you please tell me what is the reason?
Uipath Studio Version: 2016.2.6165

Regards,
Jiban


#9

Hey @jibanjyoti Jyoti Rana :slight_smile:

It is there :smiley: C:\ProgramData\UiPath\Uipath.settings

Regards…!!
Aksh


#10

Hi @aksh1yadav,
Dude i have checked. :grin:
For me its not there.

That’s why i am crying. :stuck_out_tongue:


#11

Thank you all :slight_smile:


#12

In this case %AppData\Local\UiPath


#13

Hi @badita,
I have checked the directory. I got UiStudio.settings.
Unfortunately i was not able to find the property called : Login to Console

Seems it is the layout related settings file for the UiStudio.


#14

Can you try to restart your “UiPath Robot” service please? Do a check for UiPath.settings after restart.


#15

Hi @MirceaGrigore,
I tried to restart the service but in service pane, i can see all the actions are disabled.

Note: In case i do restart my machine, by default the service is also restarted with this. I don’t think it will resolve the issue.


#16

Hey @jibanjyoti

It will need an admin rights to do so. You can not start and stop service without having admin rights on that particular system.

Regards…!!
Aksh


#17

Yes @aksh1yadav, I don’t have admin rights on my machine. If i am not wrong, all the services gets restarted by default if we restart the machine.


#18

It depends on that service “Startup Type”.

Regards…!!
Aksh


#19

All are same but disabled.What to do here @aksh1yadav. :frowning:


#20

Then you can see startup type is “Automatic Delay start” so if you will restart system then the service will also in this case ::slight_smile: