Orchestrator, missing service

In Level 2 - Orchestrator 2018.3 Training Practice 2 I’m asked to right-click the UI Icon on the Taskbar. There is not such icon. Well, " Note: If you can’t find the icon, make sure the service is running. Click here to see the instructions."
WHAT service should I start and HOW?

Hi @jkyottila

You will have to start this service manually from app data local folder

C:\Users\"yourWindowsUser"\AppData\Local\UiPath\app-19.7.0-beta0074

you can find the robot.exe

image

Once you double click this icon, you will be able to see the icon in system tray

from there you will have to click on Orchestrator Settings and connect your machine to Orchestrator

image

Thanks,
Prankur

3 Likes

Thanks! What could be the machine key? Is Orchestrator URL always https://platform.uipath.com? I use Community Edition. The system gave me the Machine name 3L-PC115C92, is that right?

You will get that from Orchestrator

image

Thanks,
Prankur

3 Likes

Fine
Hope these steps would help you resolve this
—whenever we want to get the robot tray to be visible go to start and search as robot
—click on robot.exe and we can icon coming up in task bar click on it and click on settings (wheels)
—in that setting we can find the machine name and that should used as same i orchestrator while creating machine in machine tab of orchestrator
—once after creating machine in the orchestrator we can get the machine key from there
—but before pasting there we need to make sure these stuffs
—we need to create a robot in robot tab with a robot name and machine name that we created. In the previous step under machine tab
—once robot is created we need to place it to a environment under environment tab I.e., create a environment and add that robot to that environment
—once added to the environment now copy the machine key and paste it in True robot tray in the machine key field
—yes you are right if we are using community edition then that is the url as you said
—once after mentioning these we can connect and the robot will get connected

Simple isn’t it
Hope this would help you
Cheers @jkyottila

Hi! If I run the robot.exe and go to Orchestrator settings, the machine name is always 3L-PC115C92 and I cannot change it. Why? Is it possible to have only one machine in the system?
Another problem: I cannot see anything in Jobs. What do I miss?