Orchestrator job stuck

I was going through the training. I built a job, and now i am trying to delete it. However, i get an error number #1002 Release does not exist when clicking “restart”. It also has the delete job grayed out. I don’t see any running processes in the Orchestrator taskbar.

Details/ Info that might help:
Job is in the stopped state.
Job is listed as Source:Manual

Also, I have a robot it is connected to. I tried to add a new job instead for the robot but it isn’t found saying 10/0 in the list.

My robot of license Studio Pro is showing available. I also tried changing to attended but it still doesn’t show under the job list. So I believe I provisioned the machine name and key correctly?

You cannot delete a job from Orchestrator, but you can delete a process or package. And i think that is what you have done (deleted the process).

I reproduced the error.

  • You have run the job and you stopped it, or it got stopped.
  • You have deleted the process.
  • Now you are trying to restart the job and then you will get the error:

Try this in Orchestrator:
Automations > Processes > Create your process again and select the correct environment where your robot is in.
Now go to Monitoring > Jobs and create a new job. Select your process, select the robot and run it.
Don’t see your robot? Check if it is in the correct environment

If your robot is not starting just reboot the robot machine so it is in a clean state.

You can see it like this

  1. Studio: build your project in studio.
  2. Studio: Publish your project to Orchestrator or upload it manually (package)
  3. Orchestrator: Create a process and select the package and select the environment
  4. Orchestrator: Create a job and select the process, and select the robot

If the above doesn’t work for you, please provide some screenshots and exact steps you are trying to do.

I tried following your steps, but am not having success. Here are some screen shots.

I get the error simply by going to Monitoring-> Jobs, selecting the testing2 job and “restart”. I can’t delete it. I can delete the processes. Is that how it is supposed to work? I was thinking jobs would disappear once run…?

Finally, when I try to build a new process instead, I don’t see my robot. This is true is I use either of my two environments. The robot seems to be in both. So I would think either one would work.

Ok. Skip the job restarting.
Change the type of your robot to Unattended (it is now set to studioPro). Then when you start a new job you should see your robot appear. When you have set it to studioPro you probably won’t see it when you create a job.

K Thanks. That did it. Is there a way to have both an unattended robot and Studio license available on this laptop? If I go to unattended, it breaks my Studio Community edition which goes into a read only state. Or is the process for the Community edition switch to unattended, build a job, and then finally switch back to Pro?

Good to hear it solved your problem.

If possible i should create a virtualmachine for your unattended robot. So you can develop on your studio machine, publish your project to orchestrator and run the job on the unattended robot. Switching between licenses will cause errors

You could give it a try by installing a virtual machine (with windows 10) on your laptop. Set that one as unattended robot.

I haven’t tried this setup, because i have my own servers at home for testing like this.