Orchestrator instance is populated in Japanese

I have created a new instance of Orchestrator with the latest version and although the main page is in English, the dashboard is entirely in Japanese. Can you tell me how to change the language as I can’t find a setting to do this.

Don’t worry I have found the drop down below the fold on the left hand side.

1 Like