Question/Problem
Orchestrator を冗長構成で構築しています。
SQL Server を可用性グループにしたところ、エラーが表示され Default のテナントにログインできなくなりました。
なお、host テナントにはログインできますが、そこから別の画面へ遷移すると、エラー(200)となります。
Resolution
原因:
Orchestrator をインストールしているノードにて、HAAの設定でエンドポイントを正しく指定できていない場合に本エラーが発生します。
対応:
HAA 冗長構成かつ DNS サーバー使用時には、UiPath.Orchestrator.dll.config は次のようにデータベースのエンドポイントを指定します。
<add key="LoadBalancer.UseRedis" value="true" />
<add key="LoadBalancer.Redis.ConnectionString"
value="<haa-db-endpoint>,password=<haa-password>"
/>
Related links
■UiPath High Availability Add-on インストールガイド
■UiPath High Availability Add-on インストールガイド
https://www.uipath.com/assets/downloads/uipath-haa2023-4-installation-guide
■Orchestrator導入ステップバイステップガイド