Orchestrator Email Alert

email
orchestrator

#1

I do have an issue configuring Email notifications.
Do you have examples how to configure the parameters in tab Settings?
While Email-Activity SendMail was easy to use we were not able to configure email notification via Orchestrator succesful.
Which properties in Orchestrator match to Activity-Properties:
Port
Server
Email
Password
SecureConnection - Auto
?

Who is the receiver of the notifications?
Is the settings page a configuration for each user?

Is there a possibility to check the configuration? (Send a test email e.g.)

I stopped an UiPath Robot process on a Robot an expect an email. Is this right?
Fatal Notification would be sent directly?

P.S.
We read documentation but did not help


#2

Any ideas or help @badita


#3

@Vlad_Tudoran, @Marius_Cosareanu


#4

To receive Fatal and Error alerts as email messages, do the following:

  1. On the machine you have Orchestrator installed on, navigate to the Web.config file (by default - C:\inetpub\UiPathOrchestrator).
  2. Set the Alerts.Email.Enabled parameter to true.
  3. Save your settings.
  4. Navigate to https://security.google.com/settings/security/apppasswords.
  5. Sign in using the e-mail address you want to send mail messages from Orchestrator.
  6. From the Select App drop-down list, select Mail.
  7. From the Select Device drop-down list, select Windows Computer.
  8. Click Generate. The Generated App Password window is displayed with an app password.
  9. Copy the previously generated app password to the Clipboard.
  10. In Orchestrator, in the Settings page, configure the settings as follows:
  • Abp.Net.Mail.DefaultFromAddress - the email address from which to send mail messages (the same used at step 5), in our case mada.boboc12@gmail.com
  • Abp.Net.Mail.Smtp.EnableSsl - true
  • Abp.Net.Mail.Smtp.Host - smtp.gmail.com (Google SMTP server)
  • Abp.Net.Mail.Smtp.UserName - the email address you want to sent e-mails from, in our case mada.boboc12@gmail.com
  • Abp.Net.Mail.Smtp.Password - the app password generated at steps 5 - 7 of the email address you want to use (specified in the Abp.Net.Mail.Smtp.UserName parameter)
  • Abp.Net.Mail.Smtp.Port - 587 (default Google SMTP port)
  • Abp.Net.Mail.Smtp.UseDefaultCredentials - false

As per documentation, all users that have an e-mail address configured in the Users page and an assigned role that grants them View permissions on the Alerts page receive email alerts, each time a Fatal or Error alert is encountered, and a daily detailed report.

For example, all the three users displayed in the following screenshot are going to receive email alerts:

The activities in Studio have nothing to do with these Orchestrator email alerts.

To check if the settings you provided are ok, you could stop the UiPath Robot Service (from the Services window). You should receive a mail message stating that the Robot went offline, such as in the following screenshot:


Can orchestrator send email notifications?
#5

Thank you. One additonal question:
If i want to use an email account of our own domain instead of google - how to configure the parameters Domain, EnableSsl and UseDefaultCredentials?
I only mentioned the activity in studio because there it was no issue to send an email via this account.
But i don’t know how adapt the used configuration to the parameters within the sessions page.
I tried different combinatons but no email was sent in case of offline robot. Is there a log etc. to see details or error messages?

e.g.
Is Abp.Net.Mail.Smtp.Password the password of the email account or not?


#6

Yes. The Abp.Net.Mail.Smtp.Password is the password of the email account.

Abp.Net.Mail.Smtp.UseDefaultCredentials - Indicates whether or not to use the default email credentials. Only Boolean values (true, false) are supported. This setting should be set to false if EnableSsl is true. If this is set to true, then the Password and UserName parameters are not used, even if they are filled in.

Abp.Net.Mail.Smtp.EnableSsl - Indicates if an SSL is required for the SMTP domain used (if any). Only Boolean (true, false) values are supported. If this is set to true, then the UseDefaultCredentials setting should be set to false.

Hope this helped you and good luck,
Madalina


#7

Yes it works. Thank you very much.
Last question concerning Abp.Timing.TimeZone and Reporting Time within email.
I tried different values from https://msdn.microsoft.com/en-us/library/ms912391(v=winembedded.11).aspx
but time does not change within email. Always UTC was used in alert email.


#8

Glad to hear it works!

The reporting time of the e-mail is the time you set for Orchestrator, from the parameter you just mentioned. This is because Orchestrator sends the e-mail message.

Did you add the Name of Time Zone in the Abp.Timing.TimeZone parameter? From documentation: To change the value of this field, use the Time zone names from this list, such as Pacific Standard Time.


#9

Yes i tried different values for this parameter in Orchestrator settings page.
West Pacific Standard Time
W. Europe Standard Time
Central Standard Time

But always UTC was used in alert email.


#10

@qateam


#11

Issue confirmed. Email alert is always sent in UTC


#12

@qateam
@Madalina_Boboc
please check content of daily alert summary email as well, seems to be wrong for me.

count of application exception is count of business exception so count of application exception is missing,
job counts seem to be wrong as well
.
.
.
And I would prefer to add tenant name in email subject because operation team could get emails from different tenants.


#13

@b_s sorry for the late reply. We’re still investigating the daily alert mail content. I will get back to you as soon as possible. Thanks!


#14

@b_s On my side, the count is ok regarding the Alerts Dashboard. It actually counts the number of ALERTS of robots/jobs/transactions in the last day and NOT the number of the components.
.
.
.
As for the tenant name in the email subject, i’ve created a new topic in the Ideas category. You can follow the discussion here: Email alerts: add tenant name in email subject


#15

@viorela.preda
please check the transaction counts again. We did a test last night with a new queue.

Result in Email “Alert Dashboard”:


#16

@b_s Indeed, transactions with application exception count is wrong, dev team is working on it. My point is that you should check the Alerts page filtered on Component and Interval(last day) when you want to compare the count in email. Thanks!


#17

@viorela.preda
ok

the count of occured business exceptions is listed as application exception in email “alert dashboard” (3 instead of 2)
count business exception than is 0 in email “alert dashboard” (0 instead of 3)


#18

@viorela.preda
Concerning Job counts:
In Orchestrator Alerts page sometimes i do have two messages for starting one job. That would explain the count issues for “STARTED JOBS” in email “alert dashboard”.


#19

@b_s Are they reported to occur in the same time? Because i have two messages for starting one job, but they are a few seconds apart.

I’ve reported the issue on the transactions’ count. Will be fixed in the next release. Thanks!


#20

@viorela.preda
In Alert page output just says “2 days ago” so i can’t see if same time or not.
But i’m sure i started “Add_queue” only one time that day.