Orchestrator automation executing partially and registers as a success in the jobs history

Good day, everyone!

I’ve successfully published my project to my orchestrator, but when I run the automation, it only executes the automation partially and registers as a success in the Jobs History, despite the fact that it was incomplete. I’ve been unable to resolve the issue because it works perfectly fine when I run it from studio.
Please advise on the nature of the problem.

Best Regards,
Kakooza Allan Klaus

How did you understand that it is incomplete?

1 Like

Thank you for responding so quickly, @Lak Ui.
Because I’m aware of the expected result:

The workflows in my Init sequence are encapsulated in the above image, thus what occurs in orchestrator is that it only executes up to the third workflow and then stops, despite the fact that I have workflows in my Process.xaml that don’t execute at all.

Best Regards,
Kakooza Allan Klaus

is it working fine when you run this in studio in debug mode?

1 Like

Yes please
It works very fine in studio

Hello @Kakooza-Allan-Klaus

Please confirm whether you are doing some exception handling in your workflow or you marked continue on error as true for any activity?

Also can you confirm whether some particular workflow failed to execute and plz share the screenshot of that workflow here.

1 Like

Yes am doing exception handling
Am not getting any error that’s why am wondering why the job is being registered as a success yet it is incomplete and am not getting errors

Is it specifically skipping one workflow in the entire process? If yes, can you confirm which Workflow is that and share a sceenshot of the same.

Also in your automation are you accessing any local files?

Yes, I am accessing local files.
It stops executing at the 3rd workflow it doesn’t execute the 4th one inorder for it to get into the Process.xaml

This the structure of my fies on the orchestrator:

This the structure of my files on the local machine:

Could the issue be with the project folders because they don’t look identical when you look at them.

Can you do one thing. Instead of accessing the local file, can you put that in the project folder and upload the package again.

Then try to execute the flow again.

1 Like

The local file am accessing is because and am just downloading it then I move it into the project folder then the rest of the files that I need in the automation are within the project folder.

Usually it should work. just for cross-checking I mentioned to put it in the project folder.

Can you reconfirm in which activity the execution is not happening. You can write to the log file each activity steps and confirm once.

As you confirmed the steps are not working from the same workflow, you need to understand the steps which is causing the issue.

@Kakooza-Allan-Klaus Also can you try to execute an another sample package and check whether the logs are generating or not.


I just changed the close tab activity from after the wait Download Activty to after the If activity and everything worked fine.

But now the new issue that am having at hand is the logs aren’t being populated in the logs panel
Any advise

@Kakooza-Allan-Klaus hope you are executing from the orchestrator.

Then what is the status of the job??

Beloww post is little old but may help.

Yes @Rahul_Unnikrishnan am executing from the orchestrator and the Uipath Assistant.