Orchestrator API - I get HTML as response for my GET/POST, not Json

Hey there,
I’m trying to authenticate by sending a GET and a POST to https://cloud.uipath.com/oauth/token,
however, as a response I get a HTML string, not the token in a json format.

This is the html string I geT: <!doctype html>You need to enable JavaScript to run this app.

I’m using Zapier to send the request, I tried adding “accept: application/json” and “request: application/json” in the headers but no success.
I appreciate any help.
Thanks!

Hi @Tamas_Balog

Could you try using another app to test the call? I have seen at least one app (postman) misbehaving and blocking the requests.

Hi @loginerror. Thanks for the reply. I tried with other apps and i get the right response that way, seems the problem is only with Zapier.
I also contacted Zapier support but got this response:

"Just to be upfront Webhooks by Zapier is an advanced feature so our support for it is more limited. Not because we don’t want to help but because API’s can be so different and each request can be so unique - so if you have questions about the setup regarding connecting to UIPath Orchestrator, that’s something that their team would be best suited to help with.

From the HTML that’s being returned in the response I can see the following message “You need to enable JavaScript to run this app.” so that might help point you in the right direction. If you or their team need any logs or other information from us please let me know."

I guess these two services just don’t mix well?

Actually, could you try with https://account.uipath.com/oauth/token instead? Cloud is set to forward and maybe that is the culprit here.

In general, it should work.

Has this been resolved? I am using Postman and I’m having the same issue.