Orchestrator API external apps permission scopes issue

I am trying to get the list of all processes from the Orchestrator API.
Unfortunately, I get the following message in response:
“‘details’: ‘You are not allowed to perform this operation.’,”

I figured, it is a permission mismatch, and I need to alocate extra permissions to be able to perform this action. According to the API Documentation, the permissions to view processes is “Packages.View”. Now the problem is, “Packages” is not an available App Scope, and hence cannot be set.

What would be the way to get the list of all processes from the orchestrator API?

All the abailible App scopes, as copied from the orchestrator:
“OR.Webhooks.Read OR.Webhooks.Write OR.Monitoring OR.Monitoring.Read OR.Monitoring.Write OR.ML OR.ML.Read OR.ML.Write OR.Tasks OR.Tasks.Read OR.Tasks.Write OR.Analytics OR.Analytics.Read OR.Analytics.Write OR.Webhooks OR.Folders OR.Folders.Write OR.BackgroundTasks OR.BackgroundTasks.Read OR.BackgroundTasks.Write OR.TestSets OR.TestSets.Read OR.TestSets.Write OR.TestSetExecutions OR.TestSetExecutions.Read OR.TestSetExecutions.Write OR.TestSetSchedules OR.TestSetSchedules.Read OR.TestSetSchedules.Write OR.TestDataQueues OR.Folders.Read OR.Audit.Write OR.Audit.Read OR.Audit OR.License OR.License.Read OR.License.Write OR.Settings OR.Settings.Read OR.Settings.Write OR.Robots OR.Robots.Read OR.Robots.Write OR.Machines OR.Machines.Read OR.Machines.Write OR.Execution OR.Execution.Read OR.Execution.Write OR.Assets OR.Administration.Write OR.Administration.Read OR.Administration OR.Users.Write OR.Users.Read OR.Users OR.TestDataQueues.Read OR.Jobs.Write OR.Jobs OR.Queues.Write OR.Queues.Read OR.Queues OR.Assets.Write OR.Assets.Read OR.Jobs.Read OR.TestDataQueues.Write”

Hello @Petru_Tanas!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hello @Petru_Tanas ,

Just a few minutes ago I had the same problem as yours, I could not get the List of Processes from the Orchestrator API using the endpoint: ‘{orchestrator_url}/odata/Releases’

I was getting the exact same error message “You are not allowed to perform this operation.”

To fix the problem, I added some scopes that were missing for my application. The combination I used to get it working was:

OR.Folders OR.Jobs OR.Queues OR.Robots OR.Tasks OR.Settings OR.Machines OR.Execution OR.Administration

I do not know which one of the 9 scopes I used is the one that solved the problem, that is because for my application I need this combination. If you don’t want to use all of the scopes I used, try testing the 9 scopes, one by one until you find the exact one you need.

I hope this helps you, as your question also helped me.

Kind regards,

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.