Orchestrator API Authentication Error

I am getting error when I am accessing the Orchestrator UiPath API.
Given below Headers:
Authorization With Bearer token


Not sure why I am getting error in response.

Please suggest here

Hi @autpat

check below post for your reference

Hope this helps


1 Like

That was old version of authentication,

Please check the below post for the new version

Hi Hareesh,

Thanks for details steps, I have followed the same:
Steps to do with the new API

  1. Login to platform uipath
  2. Click on the services tab and near the username, you will have three dots, click on that
  3. Click on API access and copy all the details you have there like client id, key and user id whatever
  4. Then send a post request to authenticate to the URL : https://account.uipath.com/oauth/token with the headers X-UIPATH-TenantName which you got in the above step and the body
    “grant_type”: “refresh_token”,
    “client_id”: “ CLIENT ID you got from above step ”,
    “refresh_token”: “fH5FcbEJLEm6BzuupvIBAb9V2eJkDDcQE1emAhSk-Cuoh”
  5. You will get the access token, copy that
  6. To get the folders, you need to send a GET request to the URL : https://platform.uipath.com/odata/Folders with the authorization code and X_UIPATH_TENANT_NAME as the headers.

For GET folders API I am getting same error


I have copied code in nodejs and got the below output

Please suggest here.

Can you let me know the Access token is passed correctly and what are the headers you are trying to send?

Hi Hareesh,

Yes I have given below Headers:
Authorization With Bearer token

for GET folders API

Actually looking for API solution from last 2 days
Lot of work pending because of this authentication error

If you are giving those along with the bearer token you got recently, it should work,
Can you let me know if the same bearer token working for someother request?


I have tried other GET APIs but getting same authentication error for other APIs also

I think the issue will be the bearer token, may be it is expired, As far as I know, bearer token will expire in one hour after you got it from the request, Can you try creating new token and try it


FOr every Post request for /oauth/token API will give fresh access_token.
And copying the same in other Get APIs.
But still no luck getting same error.

Is there any setting to update the timeout period for access_token api

It is working exactly fine for me,

Can you let me know how you are trying to send the requests?


Need to check with UiPath Support team. But I don’t think so UiPath will give support for Community edition.

Because problem is there from last couple of days.
Not Sure but Is it any UiPath API issue?

Please let me know this @autpat

and for community edition, we have a team here to help you. We are happy to help you until you found the solution :slight_smile:


Please go through the below request details screen shot,
Getting same issue

You are selecting bearer token as the authentication type, you don’t need to give “Bearer” along with the token.

You need to give it when you are passing the value in headers @autpat

This will resolve your issue if the token is generated within one hour


I have removed Bearer string and added newly generated access_token.
But still getting same error

Can you let me know the headers also @autpat


Please go through the below header details:

I’m not sure what you are missing here,

I know I’m asking too many questions, but can you let me know whether you are using id_token or access_token?

Can you add content-type :application/json as below