Orchestrator alerts and Outlook 365

Hey there,

my team has two Orchestrator environments with different versions :

  • Our production environment has recently been upgraded to 2020.4.1
  • Our pre-production has version 2019.10.16

And in both cases we have set up alerts for when a job fails. We use an Outlook 365 service account.

Ever since we upgraded the prod, the alerts do not work. If we try and test the mail settings, we have the following error :

MailKit.Security.SslHandshakeException: An error occurred while attempting to establish an SSL or TLS connection.

This usually means that the SSL certificate presented by the server is not trusted by the system for one or more of
the following reasons:

  1. The server is using a self-signed certificate which cannot be verified.
  2. The local system is missing a Root or Intermediate certificate needed to verify the server’s certificate.
  3. A Certificate Authority CRL server for one or more of the certificates in the chain is temporarily unavailable.
  4. The certificate presented by the server is expired or invalid.

It is also possible that the set of SSL/TLS protocols supported by the client and server do not match.

See https://github.com/jstedfast/MailKit/blob/master/FAQ.md#SslHandshakeException for possible solutions.

I have no idea how to fix this.

Thanks in advance

1 Like

Could you share a screenshot of the email settings you have configured in Orchestrator?
Also, a bug in that area was fixed in a 20.4 patch, could you try to upgrade to 20.4.3?

As for upgrading, we’d rather wait for the next LTS version which is due soon because we don’t want to upgrade too often :grinning:

Hi @MeryemAdb
This most probably the port issue
What is the protocols you are using
, such as IMAP , POP3 or SMTP

So check and use below according to ur port
IMAP - 993
POP3 - 995
SMTP - 587

Try with the port 465. If that does not work, then you will have to upgrade to either 20.4.3 or 20.10 (the next LTS).