Orchestrator abd Robot version compatibility

Hi All,

I have a robot version 2018.3 and the Orchestrator version 2018.1.4.
Please let me know will that version compatible each other or do we have to downgrade or upgrade the versions.

I have gone through the link as follows:
https://robot.uipath.com/docs/about-backward-and-forward-compatibility

Please suggest.
Thanks in advance.

Your 2018.3 robots will run on 2018.4 orchestrator, but not on 2018.1. Source.

it will still run in 2018.2.