Orchestrator 2018.2 Can't find published packages Practice 1


I’m going through the new Orchestrator training material. 2018.2

The practice materials suggest looking in C:\ProgramData\UiPath\Packages but when I publish the project (it says goodbye world as I’ve already done the orchestrator training 2018.1 which I didn’t like at all this new learning material is much better so far) anyway I wanted to differentiate between the packages from the original and the new ones (when I was doing the 2018.1 the packages did save and they are in C:\ProgramData\UiPath\Packages but now the OrchestratorGoodbyeWorld Packages are not being generated even though this message is appearing when I press publish


This is the contents of my packages folder


and I’ve done a search on the C drive for OrchestratorGoodbyeWorld with only the project being found (no package).

Does anyone have any idea whats going on here with the packages? Is there anyway to know where the packages are being created.

I’m going to restart my PC see if that helps.


Restarting doesn’t help. I created a completely new process and republished and still no package has been generated.

I don’t seem to be able to create any packages which is a bit of a problem for the whole orchestrator process

Hi @charliefik,

I guess that until you dont run the process into your robot, you wont see the package in the folder ProgramData\UiPath\Packages

Also, you can publish the package, then download in your UiPath robot or do it from Orchestrator.

Regards :mage:!

So after I publish the package I still don’t see it in my UiPath Robot (even with a refresh)

The learning materials say publish the package and it should be published locally


The next stage is to navigate to the package (but I haven’t got a package to navigate to)


this is my folder

it doesn’t contain any of the packages I’ve been publishing today

Mmmmm… Have you tried to republish your code?

Many times I had to republish the .xamls because it took a lot of time without been uploaded… So in those cases, I had to republish and it worked.

Yes tried republishing loads of times. Each time I do I get the pop up saying that the project was published successfully but then there is no package


in the folder

Still can’t locate the packages. If there is anyone out there that has had the same issue and managed to resolve it please message me.

Many thanks,

This may be the answer?

Even though I can’t locate the package in C:\ProgramData\UiPath\Packages (or anywhere else)

If I go into orchestrator -> processes and add a new process I can pick the process that I have just published.

And if I go into my system tray and open up the Ui Path Robot it’s then available in the list of processes.


Hi Clark,

This is the intended behavior, please check the documentation about publishing automation projects:

If you are connected to Orchestrator through a Robot, the automation project is sent to the Orchestrator feed, and it is displayed in the Packages page. From here you can distribute it to other Robots, by assigning the package to an environment (creating a process).

If you are not connected to Orchestrator, the automation project is sent locally to the Studio feed, %ProgramData%\UiPath\Packages. From here, you can manually send the packages to the Robots, so they can be executed.

So, when you are connected to Orchestrator, the package is published only to Orchestrator, it is not saved in local drive. But you can download it from Orchestrator when you need it.



Thank you very much @Silviu for the explanation that makes absolute sense why it wasn’t being saved locally.

All the best!