Orchestartor cannot connect to robot

Why my orchestrator cannot connect with the robot since my machine key are correct? who can help? thanks.

Hi @jiejie

In your Orchestrator robot, have you provided the proper username and the password that you use to login to your computer?

in command prompt, type whoamI and it will show you what you should enter as the username. Then provide the password for that user and it should work fine…

Let know whether this helps

@Lahiru.Fernando what u mean is this? but i cant login

Hi @jiejie

sorry if I confused. So in the orchestrator, go to the robots page where you have the list of robots there. In that page for the robot, under username you have to specify the username you use in your computer. So to get the computer username, in command prompt, type “whoami” just like that you have done above…

So once you type that, you got ght\jjtang. So make sure to use the same result under the username in the robots page :slight_smile:

Let know whether it works

1 Like

@Lahiru.Fernando

mean i need to create a username and password in here using my username and password which access to my pc? @Lahiru.Fernando

Yes buddy @jiejie…

  1. Once you enter here the domain\username and password…create a robot with the machine name of yours and add it to an environment…this can be done robots tab of orchestrator
  2. Then try to click connect in robot settings ( robot agent )…

The reason though you have entered the username and password…unless you creat e a robot you would be able to get connected…

Hope this would help you

Cheers

2 Likes

Hi sorry for the late reply…

You also need to create a Orchestrator machine too… Create a standard machine. And the machine name in the orchestrator should also be of the same name of your computer which is "ght"

So create a machine under the name “ght”. Then when creating the standard robot, select the machine you just created.
For the domain/Username use what you got in command prompt when you type “whoami”.

For the password, give the password you use to login to that user

Then…
in your local robot, there is a place to add the machine key right. So in your orchestrator, view the machine that is under the name “ght” (which you just created) and get the machine key from there. Copy that key in the local robot settings and try to connect…

This should work… :slight_smile:

2 Likes

For the robot name, you can put anything… :slight_smile:

1 Like