Opening a file with spaces and variable parts


I am trying to open an excel file with spaces and a variable part.

Example: file named “Money Report 07232019.xlsx”

I am using “Open Application” and under the argument I’m using:

“”“Money Report “”” + strDate + “.xlsx”

where strDate is a variable that gives the current date (MMddyyyy).

Problem: When I run this, UIPath tries to open an excel doc named “Money Report .xlsx” and then another excel doc named “07232019”.

What can I do to make sure UIPath doesn’t try to open two separate docs (that, of course, don’t exist)?


can you try “Money Report “+strDate+”.xlsx”

1 Like

As @MuralidharVankamaddi said, you should be able to concatenate your strings without the extra set of quotation marks. I’ve tried this on my machine and it is working as expected.


When I do that, UIPath tries to open a document for “Money”, for “Report”, and for the date.

Are you using the Excel Application Scope activity?

1 Like

can you share the screenshot of the Excel application Scope with properties ?

or the workflow?

1 Like

I was not. Thank you so much for your help!!!

1 Like

I wasn’t using Excel application Scope. Thanks for your help!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.