OpenBrowser option NewSession now totally broken in any browser

I just want to announce that a pretty important feature is now totally broken and not working anymore. I already mentioned the issue one month ago. There is was only broken in Firefox:

But now it does not open any Browser with a new Session. Not even Edge. Here is simply example one this:
OpenAnyBrowser.xaml (4.5 KB)

Please fix it ASAP.

Hi @kwoxer,
I’m testing your workflow and seems that all is working fine. In your project the attributes were not marked properly. I saw this:
When I’ve changed to this:
My Chrome browser is behaving like it should. Take a look here:


So what is the NewSession setting good for?

Until some weeks, that setting started a new Incognito browser for me. Now I have to set NewSession and Private together?

Does not really make sense.

But you are right. If I set Private to true now it works.

But to 100% this is new. Prior this setting was not needed to be set. Anyway what is NewSession good for. Does not have any impact anymore…

NewSession is useful if you have many tasks related to the browser. By selecting it your web browser opens new process with individual ID so you can work with your task on this session while other task web-browser related can be done on another session with separate Open Browser activity.

Please observe that you have another attribute like:
So you can assign this particular session to your Object variable and work with this later in the workflow.

1 Like

Ok seem to work with NewSession Parameter now. I dunno maybe I was also confused. Overall I would say Private should be renamed to Incognito or something like that.

For now solved my issue here thanks.

1 Like