"Open in Advanced Editor" not working in Check App State

Clicking on the plus icon and then on “Open in Advanced Editor” does not work with the Check App State activity. Other activities seem to be working fine. Tried with the field empty and then again after a value was already defined.


What version of Studio & UIAutomation package are you using? It is working properly with latest builds for me.

Hi Alexandru,

Here’s the information about Studio:

Studio 2021.10.5 - 2/1/2022
Enterprise License
User-mode Installation
License Provider: Orchestrator
Activation ID:
Microsoft Windows Server 2016 Standard 64-bit


Could you please give it a try on the latest preview of the UIAutomation package to see if it fixes the issue for you? :slight_smile:

Hi @loginerror,

Not sure why, but preview versions aren’t available in my Studio. What should I do?

This might depend on your company policies, but in general there should be this checkbox where you can configure what should be displayed:

Thank you, after enabling it in the filter the preview packages were available.

I tried it with version 22.4.2-preview of the UIAutomation package but the issue persists.

Thank you for double checking. I have trouble reproducing the issue. Would you be kind enough to provide a video of the behaviour when you click the “Open in Advanced Editor”?

Sure, here it is. The only way to open the Expression Editor window is by clicking on the three dots, as you can see in the video.

Tried to replicate with the latest Studio (22.4) and could not replicate the issue. Please give it a try with our latest preview or soon to be stable version.

Indeed, @alexandru. I just updated to Studio 2022.4.0-beta.8588 and now the behaviour is exactly as expected, no issues at all!

1 Like