Open Browser won't open file with spaces

Im having trouble when im trying to open a local file pdf, in my “open browser” activity.

Im getting the error: “Open Browser: Failed to navigate to the specified URL.”

The browser is trying to navigate to:

I have tried replacing space with “%20”, but it do not seem to do the trick.

1 Like

Hi @eltmo ,

The Open Browser Activity is used to navigate to websites, not for opening PDFs.
Would you be so kind as to let us know what operation you want to perform with the PDF?
There is an Activity for it which you can download and install from the Package Feed:


Kind Regards,
Ashwin A.K

hi @eltmo
In this case, you could use the Start Process activity to start/open an application/file/process. You just need to pass the path for this file. Please try it and let us know.



I need to open and read an invoice. I need to get the specific information in the different sections.

I would recommend using the
activity and then working with the output string from this activity

I have tried using that before, it reads the pdf incorrectly

Please specify in further detail, have you tried playing around with the different settings of Read PDF Text?

it has this kind of setup, and then it is not readable in the pdf format

Hi @eltmo

Can you please give a try using “Document Understanding” where you can train your PDF template and can read PDF data.

Please find the link for References.

Introduction (


First open browser activity is for url and web browser automation

If we need to open a pdf and read we can either use

  1. Read pdf
  2. Read pdf with ocr
  3. Document understanding

As you said you weren’t able to read the pdf to its exact structure with pdf activities then let’s try with document understanding

Here you go a article from UiPath how this can be accomplished with document understanding with step by step guide

Cheers @eltmo

The error was simple, a check in edge settings should be checked with “Allow acces to url files”

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.