Open Browser: Cannot communicate with the browser, please check the UiPath extension

Thank you for this. I was at the point of banging my head against the table after the update, wondering what happened.

Hey @khordination, so what was your solution to this? i have the same problem, please help.

This answer might not help but as a recommendation use always internet Explorer. Not just in Uipath but for any RPA tool the most reliable browser so far is IE.

1 Like

Hi @rmunro,
IE is the most reliable but Microsoft does not have support for that anymore. If enterprise has an issue with IE then unfortunately you are on your own. So other browsers are also crucial.
Best,
Rahym S.

You could try another approch. Try to use Open application and then insert into. That will work without any error.

Try below steps:

4 Likes

Thank you. Problem resolved

1 Like

Hello Allan and everyone who is stuck with this error. On Wednesday, using Firefox, my script worked fine. On Thursday, I got the error:
“open browser cannot communicate with the browser please check the uipath extension”.
I don’t know what changed. I tried many other solutions until I finally tried Allan’s.
After I added the 'Open Application" activity, I got a new error: “Cannot find UIElement.”
Then I reverted back to ‘Open Browser’ (Firefox) Activity and now everything works. Thank You!

After installing the extension, did you activate it?

Based on my experience, it seems that it’s related to a compatibility issue between the UiPath.UIAutomation.Activities and newer versions of Chrome. I don’t know the exact version compatibility.

I have found that updating the UiPath.UIAutomation.Activities to the latest (or at least a later) version has resolved the issue.

3 Likes

If you’re using Chrome in Incognito mode and getting this error and nothing above works, try enabling these 2 settings in the UiPath Chrome extensions when you click on “Details”.

2 Likes

Strangely enough, I received the same error for Chrome when I tried to use the Navigate To activity with an unset or empty variable.

It happened when I tested this portion of the Workflow without first setting the variable.
Similarly, I received the same error when I invoked this Workflow and passed an empty string to the argument.
image

Re-installing Chrome fixed the issue for me!

This is not an answer.

YEs -this worked for me! Thanks for the tip!

I was also facing the similar situation where every time when we run the workflow getting the UiPath extension issue although it is installed. Every time we install and run it got corrupted. The actual issue was I am using Kill activity to close the unwanted chrome browser window this was causing the chrome extension got corrupted.

Just update the uipath.automation.activities from the manage packages and it will work …hope this helped u :slight_smile:

Hi Nissy Ruth,

Can you provide us the version ID ?
I faced the similar issue on version 22.4.6.

Thanks in advance,
Nikos

Hi thanks, the issue was resolved

I see the issue was resolved but the solutions in here did not work for my use case.

I created a workflow in my development environment, tested the workflow and it was working as expected, so I transferred it into the Test environment to run every 3 hours for 7 days. Every single run was successful but as soon as I transferred the workflow to my Production machine, I kept getting error "Could not communicate with the UiPath extension for browser ‘chrome.exe’. Please make sure the extension is installed and enabled.

We contacted UiPath technical team, got on a call with them, they were not exactly sure what was wrong either and were not of much help.

What did help though was adding a 3 second delay in my workflow right before the bot opens chrome and attaches to the browser using “Use Application/Browser” activity. For some reason, that seems to have fixed my issue.

I wanted to add this to the list of solutions provided in this forum, incase someone else runs into a similar situation and this might help them :slight_smile:

Hope y’all have a wonderful day!

1 Like