Open Application: Excel Problem

studio
process

#1

In my process, I use Open Application to open Excel.
But it fails a lot, giving the error: "Open application ‘EXCEL.EXE Excel’ : Timeout reached."
When I check task manager I see the Excel.exe process that seems to be stuck.
I’d have to terminate that Excel process and try again.

I’ve also used Excel Application Scope but sometimes it fails to open Excel also, giving the error “Make sure Excel is Installed”.

Does anyone have a solution for this issue, or a way to reliably open Excel?

Thanks,
Ian


#2

Hello there,

Try these:

1.Use start process instead of open application
2.Excel application activity need MS office suite(excel) installed in the system to work. workaround would be use activity under workbook.

PS:you could use kill process activity to terminate excel.exe which is preventing open application.


#3

Hi, thank you for your response.

I just tried using start process, but excel is still not opening.
I can see the excel process start in task manager, but it gets stuck at around 4000K memory used, and nothing happens, and then the process fails.
This is the exact same thing that happens with open application.

For start process inputs, I supplied the file path under “FileName”.
Do I have to add anything to “Arguments” or “WorkingDirectory”?

Thanks,
Ian


#4

Does it open manually ok and with no popups? Sometimes if it opens with popups like the Update Links or Enable Macros popup it can cause it to hang. Also, if you are opening it over the network and it is being slow, that can cause Excel to open in Task Manager but be blank/frozen. Was just wondering if you are experiencing any of these symptoms while opening the Excel file manually.


#5

Just wondering, what about when you use Workbook Read Range activity? Are you able to get anything into a data table?


#6

@ClaytonM
Excel opens okay manually.
If I had to terminate the excel process beforehand, then a pop up would come up asking if I want to run in safe mode. I took that into account, so every time before I run my UiPath process, I would manually open excel to deal the pop up and make sure it opens correctly.
I have excel installed on my computer, not opening it over the network.

@vvaidya
Workbook Read Range activity works and stores the result into a data table with no problems.

The issue with Excel does not happen every time. I would say half the time it fails and half the time Excel opens.


#7

Hello again,
may I know which version of excel package are you using?
Excel application scope had couple of bug which was listed previously and in the new version i thinks it’s been fixed .

PS: please update excel package if available.


#8

Hi ddpadil,
I checked my excel package and I was running version 2.0.6479.13204.
I’ve updated it to 2.0.6526.16321.

The problem with excel not opening is still there, although it doesn’t happen every time.


#9

Does unchecking visible property helps ?


#10

No, the visible property doesn’t seem to affect anything.

The first part of my process requires opening Access and using a form to output an Excel sheet.
I noticed that when I disable this Access part, everything else runs more consistently without problems.
When I run the Access part first, excel almost always fails to open at one point or another.


#11

Uninstall the Office package you are having, it might happen the issue in related to it and then reinstall the package MS Office Suite. After that install Excel again and check if it is opening or not.

repairmsexcel.com


#12

Read excel Range activity is not working for Windows 10. Reinstallation doesn’t help, already tried.