Open .accde file with OpenProcess

I am using Open process activity and passing the MS Access.EXE path and using my .accde file as argument but it is giving error message…
Is there a difference between opening the accdb and accde file ?

Yup access DB file cant be opened as a independent process, should launch through MS Access only.

What exactly are you trying, why not open it using the default app? (Open application, launch new file or the existing file using uipath)

Since I have the path of the accde file with me, I would like to use open process. Open Application on the other hand uses selectors…
Is there any other way to open the accde file ?

If you want to query the items then no need to open the file at all, just build a connections string and do your thing, but if you want to open for the purpose other than the provisioned ones then you might have to go through the app. launch way. Even start process uses a path, selectors are for launching the app which also uses the path, so may I ask what might be the issue ? :slight_smile:

Thanks for the response.
I need to launch the accde file and then perform a few clicks and then extract data. Can you please tell me how to launch the accde file other than Open Process ?

Extract the DB data right? Why not use a query which is faster and reliable? UiAutomation should be the last resort when involving DB…

If you still want to open the file then you can try Open file activity. But, might not work.

This is a EUC Tool and has many macros built into it…
I need to access only a few.
This bot does not have rights to read the tables…
Manually, I am able to double click and open the file.
I am not able to give the path and open the file from UIPath

Have you tried changing the default app for the file and then trying to launch/open the file?

Default app settings should be changed to MS Access.

yes, default app is MS Access…
When you say launch or open the file, may I know which activity you are referring to ?

Pardon me if I havent been clear, -

  1. Open application activity - then open your file in that app scope
  2. Start process with ciirrecct path and args.
  3. Use batch script to open/launch your file (as you have already set the default app it shouldnt be an issue)

Below is the batch file content change acc. to your requirement

    @echo off
    cd "full path to your file"
    start YourFilename.extension

Thank You for your responses.
Solved it by passing the accde itself as the executable instead of in the argument of Open Process.


I thought you had already tried all avenues in ‘Start Process’ so I have to venture out new suggestions. Great then :slight_smile:

appreciate your support.
I have noted the batch script option for future use.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.