Only showing last excel value in DataTable

Hi All

I am using workbook Read Range activity in Excel file. (The excel file saved in xlsx extension). These excel files generated by ABBYY Flexicapture. When I used ReadRange activity only getting last value in Data Table. But when I used ExcelApplication Scope with Read Range activity then I am getting complete value.

Second: When I just open abbyy generated excel file and save it through MSOffice then also it is working file.

If need any more clarity please tell me. Need your valuable help for this thread.


This is strange,
Please reconfirm that there is no cell range given in read range activity.
Can you please share the excel and workflow screen shot for better understanding


I tried both way by putting Nothing and “” in Cell Range. But same result.

For more information the excel is generated by ABBYY Flexi Capture.


Unable to share excel due to data security reason.

Hi @anand.t

Can you elaborate how you are getting the output of read range activity and how you are printing the output.


Hi @vignesh.ks

I am debugging the work flow and seeing the value in data table in run time.


You can see the output of DataTable like the below method. Try this and let me know still you are getting only the last value.