One or more errors occured --> Value does not fall within the expected range

Hello,

I’m trying to automate some work in a web application and it worked fine two days ago but since yesterday I always get the following error when I try to click on a UI element. I already tried to change the selector and delay the click but nothing worked. If I disable this click I get the same error two clicks later.

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.AggregateException: One or more errors occurred. ----> System.ArgumentException: Value does not fall within the expected range.
at UiPath.UiBrowserClass.get_node()
at UiPath.Core.Browser.get_Element()
at UiPath.Core.Activities.Target.<>c__DisplayClass29_0.b__0()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
— End of inner ExceptionDetail stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Does anyone know how to fix that?

Many thanks in advance.
Best regards
Julia

Check all arguments are correct when invoke workflow. Also Check your browser type as well.

Do you have any screenshot.

1 Like

Hi @Theepan,
Thanks for your answer. I didn’t use any arguments just some variables which should be correct. I used the Internet Explorer and chose the selector with the UI explorer.

What kind of sceenshot would be helpful? One of the code where the error occurs or of the error message?

Best regards

yes. exact point of where it shows the issue.

1 Like

It is always exactly two clicks after the first “click span” in this screenshot. In the screenshot the error occurs within the “Click text area” but if I put “Click text area” before the second “Click span” it occurs within the “click span”. So my guess was that it has something to do with the first “click span” but I cannot solve it.

image

Do you have an idea why I get this error?

Did you try with Simulate Click Attribute enabled

1 Like

I’ve just tried but it didn’t work either. I get the same error.
Do you have any other suggestions?

Many thanks!

can you paste here your selectors.?? or even screenshot of your selector. Which version of studio you are using.

I hope you should more narrow up your selector using UiExplorer. (Specially using class or aaname instead idx)

1 Like

Here is the selector of the click text activity:
image

I use Uipath Studio 2018.3.2. Community Edition.

Thanks I will try it with another selector.

I narrowed all selectors and used aaname or class but it’s still the same issue :frowning:
No matter where I try to click I always get the error exactly two clicks after the first one in the screenshot.

Is there anything else I could try?

hi @juka may be class selector also changing, why don’t you use parentid or parentclass.

1 Like

Hi @Teja_L,

I just tried it with parent id and parent class and it worked once but not the second time I’ve tried. I used this selector now:
image

Can you select the same selector again. So that we know any changes with this selector.

For me it looks like nothing has changed:

<html title='Unycom 2019.1' />
<webctrl isleaf='1' parentid='tab-item1__7' tag='SPAN' aaname='Dokumente' class='x-tab-strip-text ' parentclass='x-tab-strip-inner' />

Is it possible you to share workflow?

I have an appointment now but I will do that later.

Thanks a lot for your help.

If it is happening inside open browser and attach browser , you can refer this : UiPath - Value does not fall within the expected range

1 Like

It is indeed inside of an open browser but the tips in the topic you mentioned did unfortunately not solve my problem. I can do two more clicks now before I get the error but it is still there no matter how I change the selectors.

But now it does not always happen at the same click but the error changes between two different ones that should be done one after another. Does anyone have an idea why this happens?

Many thanks in advance.

@juka If possible share your workflow.

This is the workflow:

It’s a bit messy as I’ve changed a lot in order to avoid the error.

Thanks for your help.