One of my Ui Path project is going "Not Responding" when I make a change and save

One of my Ui Path project is going “Not Responding” when I make a change and save . It is impossible to make a change. Also following warning is in the Studio.log file.

16:14:08:250 => [WARNING] [UiPath.Workflow.Logging.StudioTraceListener] [6] SharpSvn.SvnInvalidNodeKindException: ‘C:\Users\digitlabs\Documents\UiPath\Redirect’ is not a working copy
at SharpSvn.SvnClientArgs.HandleResult(SvnClientContext client, SvnException error, Object targets)
at SharpSvn.SvnClientArgs.HandleResult(SvnClientContext client, svn_error_t* error, Object targets)
at SharpSvn.SvnClient.Status(String path, SvnStatusArgs args, EventHandler1 statusHandler) at SharpSvn.SvnClient.GetStatus(String path, SvnStatusArgs args, Collection1& statuses)
at UiPath.Project.SourceControl.SVNSourceControl.<>c__DisplayClass53_1.b__0()
at UiPath.Project.SourceControl.SVNSourceControl.SVNClientAction(Func`1 action)
at UiPath.Project.SourceControl.SVNSourceControl.GetSvnStatus(String path)

This is some SVN error where the folder .svn is missing in the local where you have the code. Try to clone the project again from SVN to another folder and then try to make changes

Thank you HareeshMR for your response.

I do not use any repository such as SVN.

Close all project related files, uirobot, studio and try again.
also - check the license related to your studio


Oh, then Can you try reopening the project and studio, else try to copy the project to some other folder and open from there

Thanks for the reply GBK.

I closed all and check and UI Path also in activated status too. But no any luck .

@Nilaksha_EA -
Which version of the project modifying in which version of studio? is it 2016/17 project modifying in 2019/fast track?

This is the version.

can you share the entire error screen shot!

this could be a version related issue with studio… try to raise a service request with support team and check…

Tried it now. But same issue prevailing.

Yeah, as you are an enterprise user, you can check that with the support team @Nilaksha_EA . But this has to work. Not sure why this is happening,

Just give a try by removing the project.json file (after taking the backup) and then try installing the dependencies again running the workflow

I did that too… But it doesn’t work. Project is executing properly only issue is it doesnt let to save it after any change. The whole studio goes not responding when do the same.

Can you let me know what is happening when you just leave it as it is after studio not responding error?

It may be due to the RAM space as well. Restarting the machine will help you in some cases as it will clear the RAM space

It keeps on going “not responding” and finally I go to task manager and end the task.
RAM has 16GB space and tried restarting as well.

@Nilaksha_EA Have you tried restarting the System and not just UiPath Studio?, It worked Fine for me when restarted :sweat_smile:, Also Can you tell us When did you start getting this error or have you tried to download some packages and then did the error arise?


It’s just confusing, try to zip and send it someone else. Then ask them to save the file by changing something. Please let me know if that works

Issue resolved with the installation of Ui Path 2019. Thank you all for the support given :slight_smile:

1 Like