OCR on premise - How to set up

Dear Community,

I’m trying to set up OCR on premise following the documentation: https://docs.uipath.com/ai-fabric/docs/ocr-engines-installation

Unfortunately, the configuration table for UiPath and OmniPage OCR simply say Enterprise Plan for ocr.key

I’m currently using the Enterprise Trial of UiPath (on premise) so I have no idea where to get those keys from.
I already installed Docker (Desktop) as well as downloaded and started the docker container without problem.

But when I try to use it (via on premise datamanager) I don’t know which API key to use.

I tried it with OmniPage and UiPath OCR but always get the error: HTTPConnectionPool(host='k91cs-porc01', port=5100): Max retries exceeded with url: / (Caused by NewConnectionError(': Failed to establish a new connection: [Errno -5] No address associated with hostname')

But when I try to access it via browser I get a response, so I know it is reachable.

Has anyone successfully installed OCR on premise and used it with either datamanager or AIFabric?

Cheers,
T0Bi

1 Like

I haven’t gone through the setup before, but I believe If it isn’t readily available in your Automation Cloud portal (https://cloud.uipath.com/ > Admin > Licenses > Other Services), I would suggest reaching out to Support to see if they offer a Trial of AI Fabric while using the UiPath Trial.

  • An AI Fabric license file provided when you first purchased AI Fabric is required to complete the installation. This file should have been given to you by your Sales Executive or from the UiPath Deal Hub team. If misplaced, this license file can be provided by your customer success manager or our support team. This license file contains the number of AI Robot licenses for your instance. For an explanation of an AI Robot as a licensing concept see About AI Fabric

Hi @codemonkee,

thanks for your quick answer.

I used the Document Understanding API key and it worked (:

Although I think my main problem was, that the data manager docker container couldn’t connect to the omnipage ocr docker container which I fixed as well.

I do have another problem though:

I want to use the digitize document activity with my (local) OmniPage OCR. But there’s no way to change to which API the OmniPage OCR activity connects to.
I’ve set up everything on premise, how do I actually use my on premise OCR?

Cheers,
T0Bi

1 Like