Object reference not set to an instance of an object!

Hey everyone, I encountered this error when I want to manipulate the data in a specific column.

In short, that’s what I want to do: extract the data from a specific row, after that to extract a single piece of information from the entire line.(ex: row OBS->line content: “Order #224150852 Mihai Lov” ->output: just “#224150852”.

When I do the manipulation on the line … when I run I get this error.

Hi @Copariu_Victor

Can you share the screenshots of your workflow

The data is blank, use try catch activity

Hi @Copariu_Victor

Are you getting this error on the first iteration itself.

Just make sure that dt_excel is not empty and there must be a column with the name “Obs” (check for spaces in the column if any)

…so its a problem because i have empty space? like this?

if I run the program like the one above…I have no errors…the problem arises when I want to remove only the number from the whole string

Hi @Copariu_Victor

Can you show us, how are you extracting the numbers?

because it appears, while extracting the number from the string the variable is not getting any value as no value is being extracted

When i try to split…i have this error


Can you share the sample excel and xaml

I discovered the problem…there is no pattern regarding the spaces in the houses…THX so much :smiling_face:

Try this next time,

Create a breakpoint at the ‘get row item’.
Run in debug. When the robot stops at the breakpoint check the Locals panel

1 Like