Object reference not set to an instance of an object.”

Hi All,

I am facing the problem while passing the variable/arguments from one workflow to the other.

1.I am able to extract the data from the grid(System1_ExtractWorkItemDataTable)–getting the count as 90 rows…this is fine…
2,Now I am calling the above work flow file(System1_ExtractWorkItemDataTable) from “InitAllApplications”, and here I am trying to filter out the data.–getting the count as 13 --fine.
3.when I try to retrieve resultant count from GetTransaction data, I am facing problems…
because of the passing the variables/arguments not as expected and facing error saying “Object reference not set to an instance of an object.”,(failed to set the values/arguments at Main.xaml)
Gone through various other posts and tried, then facing various other errors.
Could some body please look into this and help me.
RoboticEnterpriseFramework_Test (2).zip (519.3 KB)

Hello @shrav
Set transaction item argument in get transaction workflow with in_transaction variable
Thanks

1 Like

For reference see screenshot

Thank you Sandeep for the Response.,
But the mentioned variables have been already set as the same. then also I am facing the issue.

Here List of screen shots attached.

1.Calling the GetTransactionData:
image
2. Invoked Arguments List:
image
3.Variables List:
image

  1. Arguments:
    image
    5.GetTransactionData_Arguments:

image

Hello @shrav
I talking about argument of get transaction workflow

Again Thank you very much for your faster response…

Yes Sandeep…my 2nd screenshot is the same(passing the same i.e. transactionItem and transactionNumber).
But before to that even I m not able to get the count of the filtered data(in_WIList.Count)…please find the below screenshot.
Thank you for your time and patience.

Hello @shrav
I go through your project I seen in initallapplication workflow

  1. image
    please change scope of WIlist variable

  2. pass that variable in value of out_WIList variable in INIT workflow
  3. then
    its work on gettransaction workflow

hope its help.let me know if you face any problem

thanks

2 Likes

No luck Sandeep… done the changes as per your instruction but still facing the same error at same place…

ClientSecurityHash1.zip (1.7 MB)

check this once

I modified the code as per the shared one(changed the code structure), then it is working fine, but still I am looking why the old code has that problem… where I did mistake…looking for that…

Thank you very much for your response and time…

1 Like

cheers buddy @shrav
please mark as solution that post so that helps to other

thanks

Happy Automation

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.