Not able to use any citrix automation or type anything into a remote desktop screen

Hello all,

I am trying to change the password in a remote desktop machine. I can log in properly into the remote desktop and access the password change screen using the send hotkey activity (ctrl - alt - end).

So, in there, I just type into “[k(down)]” + “[k(down)]” + “[k(enter)]”, so I can click on “Change a password”. I am uploading the following image so you can know where I do so:
(note: “Cambiar una contraseña” means “Change a password”, as I stated before)

The problem is that, once I do that, I am not able to type or click on anything on the screen that changes the password. I have tried the click image, click text and the type into activity, and none of them would work. If I try to do so manually I am able to type anything.

Do you know any way to do so?

This one is the screen I have problems to type anything with.

Thank you in advance.

I have tried to change the password via cmd using the net user /domain command, without sucess.
When I type net user username /domain, it works, but when I try typing net user username password /domain, I get the error 5 “Acess is denied”. Therefore, I cannot change the current password this way either.

The first way I tried (the one I’m showing in the original post) works out well manually, though it doesn’t work when being automated with UiPath as I mentioned.

Thank you.