Not able to take screenshot in PIP mode


I tried taking the screenshot using below ways but its not working

Classic - Take screenshot activity, by providing clipping region and also tried with selectors.
Modern - Take screenshot activity, with File/Image option and also tried with Enabling Target
property as TargetAnchorable. (I use this inside use application/browser scope)

Both of them are not working, can someone help me with it.

Hey @SayRPA

Did you get any error, please ?


I already tried below ways,
Classic activity –using clipping region property or blank properties

In this case getting below error,
Take screenshot: System.ComponentModel.Win32Exception (0x80004005): The handle is invalid
at System.Drawing.Graphics.CopyFromScreen(Int32 sourceX, Int32 sourceY, Int32 destinationX, Int32 destinationY, Size blockRegionSize, CopyPixelOperation copyPixelOperation)
at System.Drawing.Graphics.CopyFromScreen(Point upperLeftSource, Point upperLeftDestination, Size blockRegionSize, CopyPixelOperation copyPixelOperation)
at UiPath.Vision.UiImage.FromScreenRegion(Rectangle region)
at UiPath.Core.Image…ctor(Region screenRegion)

Modern Activity – using both File/Image option
In case of modern activity, not receiving any error but it also not taking/saving any screenshot.

This looks like the session getting disconnected when the bot runs.

While running the workflow If I switched to PIP session then these activities worked fine. In case of running from main Session these errors are coming


Were you able to solve and get the solution of this problem?
I am facing the same issue.

Kindly let me know.