Not able to find the library in the Package Manager

Hi,

I created a custom library and wish to install the library from the package manager. I am not able to find the package in the list of ‘Manage Packages’. I have published the package and able to see the .nupkg in the folder C:\Users<user name>\Documents\UiPath\Library. Please guide

Hi @Ruchi_Srivastava,
Packages in manager are showing based on Feed provided in the Settings tab:
image

PFA snapshot of the feeds in my settings tab: I am still not able to find the library.

Please check if you are publishing package in correct folder. I made a test and everything is working:
image

Thank you Pablito. This is working now. I corrected the path/folder.

1 Like

But I am facing a new problem now:
“Authenticate: Could not invoke client method.” This may be because it’s not able to make a connection with Orchestrator.

I have entered the username and pwd except Tenant nameimage . Is this correct?

I don’t know what exactly your library is doing and what do you want to achieve.

This library has been created as per the UiPath 2019.4 Updates course (SOAP and Swagger Libraries) available .

This can help you :slight_smile:

@Pablito I went through the above post. This seems a little complex as compared to the 2019.4 training course. I am still trying to figure out to make it working but havent been able to so far.

I am getting the attached error:

This is still not working. I will appreciate if any leads/hints.

Regards,
Ruchi

Hi @Ruchi_Srivastava

Please go over this post:

Unfortunately, the authentication is much trickier with platform.uipath.com becoming a cloud service with better authentication.

This means that the first activity Authenticate will not work anymore. You will need to get your access_token first using the procedure from the post I liked here and then use it as you would bearer_token.

I hope it makes sense :slight_smile:

@loginerror : Can you please share the 4 xaml files (GetTokens, getAccountsForUser, getAllServiceInstances, getLicense) once again for reference, as I am not able to open the xaml files
Error2

Could you try unpacking the entire project and opening the project.json with Studio instead of the specific xaml files?
You can also use the Open project option in Studio and point to the project.json file.

Make sure to unpack it anew again.

It should then download the proper dependencies and properly display the project :slight_smile:

Hi @loginerror, I have unpacked the entire project and also downloaded the proper dependencies. It’s working fine now.

I have one question though - My original project does not have Authenticate activity anymore but I am not able to understand how to link the original project (StartProcess_SpecificRobot) with the 4 xaml files shared. Please advise. Sorry for asking too many questions :frowning_face:

Regards,
@Ruchi_Srivastava

Hi @Ruchi_Srivastava

Please refer to the post here:

The part about using the new authentication from Services :slight_smile: