Not able to find Nuget Installed Package in Activity Tab

HI Guys,

I’ve installed watson tone analyzer from manage package > nuget.org. and it got installed successfully. And in Project Tab > dependency section i can see it’s been added. But i’m not able to see IBM package in Activity tab but if I install any package from GO!, Official it show in Activity tab.

Any suggestion?

I have attached screen shots

  1. dependencies

Any help !!

Thanks

@Varun_Kumar_Verma

Welcome to the UIpath Community.

Check whether this package has any dependencies. If yes then install it and give it a try.

2 Likes

@lakshman

Hi Thanks for welcoming me !

Yes, I have installed all the dependencies Still no luck to see the package in Activity tab.

1 Like

Hi @Varun_Kumar_Verma

Welcome to our UiPath Forum! :slight_smile:

Could you link the Go! package that works for you? It would be interesting to see if these are the same packages.

It can be that the package you get from the nuget.org feed is not optimized to be used with UiPath. You might therefore access to the namespace it provides in your assign activities, but you might not have activities to drag and drop.

1 Like

Hi @loginerror

Thanks for reply but i cannot change source for GO!

So in image we can see that GO! is default package but nuget.org is not, while nuget.org is defined by software itself during installation.

I even tried MySql.Data from nuget.org it installed successfully and i can see in dependency but not in activity.

I am still not sure which is the exact name of the second package that you want to install from the Go! feed. It would help a lot to know that :slight_smile:

For the packages that can be installed but are not visible - this is normal. Not all packages will show up on the activities list. Practically only the ones from our official feed as well as from UiPath Go! feed.
But those from nuget.org will most likely not show up. These are just namespaces for functions that can be used with some code instead.

1 Like

Hi thanks for reply,

I’m trying to get IBM watson packages which can be found in nuget.org

image

So here in Image we can see we have IBM.Watson.SpeechToText.v1 or IBM.Watson.NaturalLanguageUnderstanding.v1 so this are the packages i need to use which are developed by “IBM”. But Even I install all of them i don’t see any package in activity tab.

In My last reply i tried to show apart from this packages none of the other packages are also showing in activity tab which are installed from nuget.org.

Hope this can make my question clear
Thanks

Indeed. I believe you will need to code a bit, as this package does not have a drag and drop activity available (mainly because it was not developed directly for UiPath).

See here, the namespace is available after you install the package:
image

I suppose you will need to read into the documentation of the package as linked in the package description here: