Not able to edit the activities after uploading nupkg in studio

Hi all,
I tried to upload a nupkg in the studio and im not able to edit the activities . Can soeone help me here


Looks like some issue witht he ui or the activity pckages

  1. Did you try closing and reopening the project?
  2. Try to rename the project.json and reopen
  3. Try to change the system packages version and check if it resolves


@parvathi_ayanala are you trying to edit NUPKG Package
Try to Edit properties

You’re on the Outline tab, not the Properties tab.

hi raja .yes im trying to edit nupkg . The activities im not able to edit. here i have for each activity . inside that activityi have some sub activities if you see in the outline . in the studio im not able to edit that activity.

@Anil_G hi. yes i tried to change the system package versions already. i used to have runtime.activities packages . i removed and reinstalled the packages


May I know what runtime activities are you talkin about?

Also did you extract the files from
Nupkg and then are you trying to edit?


Rename nupkg package and change extension to .zip
After this try to extract it and go to lib folder and open your code

You aren’t trying to edit the .nupkg you’re just trying to expand the For Each File in Folder activity.

Have you closed Studio, rebooted, and reopened Main.xaml?

Close it from studio, change its extension to .zip file after that extract it and open extracted folder and open main file from lib folder.

That’s not what the issue is.

@raja.arslankhan i renamed the nupkg
here i used the json file

so when i extracted the nupkg , and opened C:\Users*****\Downloads\REFRegxExtractor.1.0.13\content
i have UiPath.UIAutomation.activities.runtime

Can you tell me why you are using runtime activities package, i think so due to this you are not able to edit this. You should use uiAutomation.Activity package

Try to insatall UiPath.UiAutomation.Activities package and after that try to edit.
Because your activities come under this package not runtime one.

after removing runtime packages and installed all the depencies accordingly. that was my first image attachment

Ok do one one thing:
Close the process from studio.
Create copy of json file and place in another folder as a backup and delete the json file from project folder.
After that open main file again let c what happen.