Not able to click on a drop-down (when a new chrome tab opens)

I am trying to click on a drop down, it works fine when i only run that portion, but in my scenario I have to click on a button which opens a new chrome tab where I have to click on a drop-down (Which is not working) and getting this error

could not find the user-interface (ui) element for this action

I am using nested Use application/ browser, here are screenshots of them
1st use application/browser


2nd Use application/browser

here is my flow screenshot

@Sami_Rajput

is it the same screen??

also did you select the right browser before indicating?

cheers

YES, i indicate the right browser tab.
Yes, it’s the same screen(If you mean multiple desktops)

@Sami_Rajput

I see in both use application/browser you are using same url…may i know the reason

also can you check the selector you have

also if you are using hardware events then the right window needs to be active …so can use activate first

cheers

Hello

Please inside of the use Application/browser leave only one activity, don’t let Application/browser inside of another Application/browser.

in the Url try to leave only the domain of url for example vendorecentral.amazon.me (check for incorrect spelling).

its not the same, its different from the ending

@Luciano_Gjinaj @Anil_G
Tried with the domain only, still same issue.
As I mentioned the second tab appears, and on that tab web page i have to click on a dropdown so thats why i am using “Use-application browser” to activate that…
image

And this logic is working fine with my other automations

in the second tab find the differences on url so it can be be indicated, i said that bcs amazon have some id which change every refresh, and don’t let any nested use application browser.

if those doesn’t help, please provide us the urls, screeshote of flows. It will be better when you highlights the browser of second “Use-application browser” to highlight only the new open tab

@Luciano_Gjinaj
1st URL
https://vendorcentral.amazon.me/po/vendor/members/po-mgmt/recent-modification?typeId=cancelled
2nd URL
https://vendorcentral.amazon.me/po/vendor/members/po-mgmt/order?poId=514LLR6O
Note: When the 2nd tab loads completely then its url changes to
https://vendorcentral.amazon.me/po/vendor/members/po-mgmt/order?

try in the second “Use-application browser” use url vendorcentral.amazon.meorder?

but leave a delay about 3 second (before the second “Use-application browser”) to let the website fully loaded

Thanks @Luciano_Gjinaj
adding a delay worked

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.