Not able to add Custom Activity in UiPath

studio
custom_activities

#1

Hi,

I have created a custom activity named “DocumentCustomActivities.1.0.0.Release.AnyCPU.nupkg” and saved this file into packages folder under UiPath folder but when I try to add this custom activity in UiPath Studio I am not able to search this activity. It’s not appearing in Available Packages section.

Please suggest.


#2

@dear.saxena

Please have a look at the link https://www.uipath.com/kb-articles/how-to-include-external-dll


#3

Thanks Gourav but I have already gone through these articles and having issue while searching the custom activity in UiPath Studio.


#4

Hi,

Right click on package tab Select Configure Sources from the context menu. The Package Source Settings window is displayed.
Click the Add and browser you package.
https://www.uipath.com/guides/managing-packages


#5

Thanks ddpadil, It is now appearing on Available packages list in “Manage Packages” window but how can i drag this activity in work area as its not appearing in Activities panel?


#6

after adding you probably see your package name in left side of tab .Proceed with installing package then restart you UiPath and then search in activity pane with relevant activity name.
If still doesn’t show up then add your nuget pacakge to %localappdata%\UiPath\app-2016.2\Packages folder.*


#7

Thanks ddpadil!!!

It finally worked :slight_smile:


#8

I had the same problem,

i had instlled “freespire.pdf.3.2.0” but i did not find any activity related the “spliting” pdf file ???


#9

I have the same issue .I was able to install custom package from package manager.but i dont see it in activities pane.

Please help!


#10

Copy the nuget package to the package folder and give a try.
C:\Program Files (x86)\UiPath Studio\package


#12

It’s been already mentioned in previous comment and he done that already.


#14

sure mate why not .Just make sure you read entire post before replying.:rofl:


#16

LOL i’m still laughing.
:running_man: Signing off …adios
It’s all yours man.

Heard enough now .
Good bye all and thanks you


#18

I’m running 2017.1*, and I am having the same issue. I am able to install the activity, but it does not appear in the activities pane no matter what I do. I’ve tried to put the nupkg in a custom folder, as well as in the 2017.1*/Packages-folder within AppData/UiPath.


#19

Same problem here. Can’t find it in activities panel.
@TDagsvik did you find any solution?


#20

Unfortunately not, and it’s a real bummer. Please let me know if you are able solve it!


#21

Hi @TDagsvik, Finally I did it using this link.

and put a nupkg in the following path. (Mandatory)
“AppData\Local\UiPath\packages”


#22

I’m happy that you worked it out!
Unfortunately, I have already tried placing the NuGet package within the AppData…\packages folder, but with no luck.


#23

Open up your nupkg file with a zip tool to make sure the .dll you required is inside.If you happen to be in a corporate network, try connecting to a public wifi or tether your mobile data, before refreshing the activities list. You do not need to drop this anywhere onto your appdata or programdata folder. First, did you install using uipathplatform.msi, or uipathstudio.exe ? I have tried both, and most of the time it is related to the .nupkg not being properly packaged.


#24

Thank you very much for your input!

I found the solution - and I really hate myself here - it seems I forgot to add a lib folder before adding the .dll when creating the nupkg. Rookie mistake, my bad!