Non Production license is not working


We have two licenses 1 is Unattended bot license and 2 is Non Production license. I assigned Non production license for DEV server and unattended bot license for PRD server. But the issue is When I assign Non production license in DEV system, after I connected UiPath assistant it shows Connected, Unlicensed. Then I assigned unattended bot license for the same system and now it shows Connected, Licensed. How can we assign Non production license?

Before assigning unattended bot license

After assigning unattended bot license



1 Like

(post deleted by author)

Hi @rprasa ,

Could you pls share your bot configuration screenshot in orchestrator while applying non production license. And double check if you are selecting correct type while allocating license. Thanks.


I could see you have opened a similar topic few days before
And also that you were able to get it licensed by opening it as admin

Over there I could see in UiPath assistant for non productive license, that the robot is not yet created

So have we created any robot in orchestrator with non productive type and connected that to your machine

Pls follow these steps to connect your machine (robot) to orchestrator

Then it won’t throw this error

Cheers @rprasa

Hi Piotr,

After providing Admin access to the user, the non production license is worked (Connected, Licensed). But after removing admin rights it’s not working. I have also tried to open uipath assistant as Run as Administrator but it’s Connected, Unlicensed. At the same time if I update unattened license (as 1) it’s connected, Licensed