No XML activities are loading when I'm trying to create a bot using Uipath Library

No XML activities are being loaded when creating a SOAP web service. Can someone please help.

Did you first add the activity under “Manage Packages”? You need to first add the relevant package before you can use it.

And then search for SOAP or xml that you want to install.

Waseem,

I tried that way. But still no luck.

BTW, I’m creating a library and loaded the SOAP web service (WSDL) file by creating new service.

Hi @chatlapalli_naveen

Which XML activities would you like to use? If you mean these:
image

Then I think these are part of the UiPath.Web activity package:

As to the loaded library, please check your Activities pane for the name of the namespace you gave it when loading it. There should be a folder with all the endpoints in it :slight_smile:

1 Like

Thanks this resolves my error. But can you please let me know, how to pass the xml data into a SOAP request.

I can see you are on the right track. In that field, simply put your xmlInput variable.

Then, for your initialization, try to open a parenthesis at the end: (
image

It should give you a tip what type is expected there.

This is the error I’m receiving now. Can you please give me an example of how to pass a XML Request into a custom variable type?

Could you post a screenshot of what is displayed after you put that initial ( sign?
It should have read the type and be able to hint you about the types.

You can also try with a . instead of ( to see if there are any methods first.

When I put “(” this is what it shows.

This is the error when I’m trying to pass the xmldata (string) into my xmlInput (custom data type)

Indeed, it simply won’t take a string like that. It might be that it has more methods we have to explore. Could you try adding a dot at the end . instead of a ( and see what will be displayed.

It might give you a hint.

You are correct. However, it doesn’t give me an option when I use “.”

Instead, when I try to do the “.” for xmlInput (custom variable) it gives options like this.

Have you managed to solve the issue? :slight_smile:

Maybe my blog here could help a bit:

I have to initialize multiple inputs in it, it could give you an overview of how to do it.

I also wouldn’t mind checking your particular service, but you would have to share it (which I realize might not be possible).