No transaction data, level 3, assignment 2

Hey @MGMKLML I am also facing same issue even after I adjust the selector… How did you fixed this issue? Will you please share selector or screen print?

Thank You,

@NavneetPanpaliya, Could you please remind me tomorrow? Also could you specify which one selector do you need?

@MGMKLML @NavneetPanpaliya

i have same problem, i think we need to change the selector for searching for next page exists or not.

but that step is implemented once it enters if condition, so where do the prob exists,

anyway initially the out_TransactionItem will be null, so obviously it wont be true.

@MGMKLML please let us know what u did


@phyogananda, @NavneetPanpaliya, in the ‘Element Exists’ activity where we check the button the selector is:

"<webctrl aaname='" + in_TransactionNumber.ToString + "' tag='LI' />"

In the part where we click the page the selector is almost the same:

"<webctrl aaname='" + in_TransactionItem + "' tag='LI'/>"

After I’ve done like this it worked and returned no any errors or something.

Hey @MGMKLML, I am not getting any error message but when I ran Main.xaml it is not processing to next page and System1 site is simply logout so don’t know where is the issue. Please help me to resolve this issue.

I used 1st selector in GetTransactionData.xaml

2nd selector in Process.xaml

Thank you,


I hope Below posts would help resolve your issues!

1 Like

@NavneetPanpaliya, Yeah, the order is wrong. You firstly attach browser and then use the if section :slight_smile:

I tried changing sequence but still facing same issue without any error message

@NavneetPanpaliya I don’t have a good idea at this moment. Could you share your project here? I could try to take a look at it myself and see what could possibly go wrong


it worked for me, need to change flow as well values and properties

send your gettrasactiondata and process workflow screenshot


@MGMKLML, @phyogananda, @NavneetPanpaliya

Can anyone let me know on what are the import arguments for the invoked Get Transaction Data Workflow ?


What are the import arguments for the invoked Process Transaction Workflow ?

out_Transactionitem is string type in below screenshot…

1 Like

Thanks @phyogananda!

Hi @phyogananda, @MGMKLML, @NavneetPanpaliya,

While running the Dispatcher workflow, “Element Exists” in “Get Transaction Data” returns a “False” value instead of “True” . Could anyone please let me know on why it is returning a value “False” ?

I have used the below selector :

<webctrl aaname='&quot; + in>_TransactionNumber.ToString + &quot;' tag='LI' />


selector is correct, but your problem is you using edit selector after pointing to the object.

use it like this, just add element exists activity and go to edit selector paste the selector.the element exists should be inside the attach browser window


Hello @PrankurJoshi, @phyogananda, @MGMKLML, @Mahesh_Lakshmipathy ,

I am done with Dispatcher workflow but program is not moving to new page and did not fetched any data. Even its not giving any error message so don’t know where I made a mistake. Please help me to correct it. Here are the attached workflows for your reference.

GetTransactionData.xaml (14.5 KB)

Process.xaml (14.7 KB)

Thank you,
Navneet :slight_smile:
Happy Automation!


I had a similar problem and it was actually a selector issue in GetTransactionData Workflow.

And @ClaytonM was glad to help me out here…

if you want to use a variable in your selector, you will want to edit it as a string. To do that, you need to close your Selector editor and open the Expression editor, which you can do by clicking in the Selector property and you’ll notice that the selector is surrounded by quotes.

Edit the string inside the property box, or delete a character and it will open the Expression editor to make it easier.

I would first get your selector back to normal as it was originally so you can edit it correctly.

Your selector string should end up looking like this:

"<webctrl aaname='"+in_TransactionNumber.ToString+"' tag='LI' />"


Mahesh Lakshmipathy

Hey @Mahesh_Lakshmipathy, I guess you did not looked my workflow which I attached in my post. I already have same selector but still it not moving to next page and not getting any data.

Thank you
Navneet :slight_smile:
Happy Automation!

i am not able to see any prob in that, better you try using debug mode to see

  1. TransactionNumber is getting updated i.e, it will start from 1 and incremented by 1 everytime

  2. Transactionnumber is assigning value to TransactionItem

  3. IMP : " Repeatforever is false for Element exists"