No robot available for use

Done exactly that, the robot is registered with orchestrater, and it can be triggered from orchestrator and it runs. However i can no longer Debug or run the process in the studio. it throws an error as pop up screen
"[Window Title]
UiPath Studio Error

[Main Instruction]
No robot available for user JOHNN

[OK]

as soon as i disconnect the Robot from the orchestrator the proccess can run when i press the play button or in debug in studio.

Log File shows this error:

21:40:59:244 => [ERROR] [UiPath.Workflow.Logging.StudioTraceListener] [85] System.ServiceModel.FaultException: No robot available for user JOHNN

Server stack trace:
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at UiPath.Models.IUiPathRemoteContract.StartJob(Stream jobInfo)
at UiPath.Models.UiPathProxy.StartJob(JobModel job)
at UiPath.Models.UiPathDuplexProxy.StartJob(JobModel job)
at UiPath.Workflow.Execution.WorkflowRunner.StartJob(JobModel job)
at UiPath.Workflow.Execution.WorkflowRunner.Run(String workflowFilePath, String projectName)
at UiPath.Workflow.ViewModels.MainViewModel.RunWorkflow()
at UiPath.Workflow.ViewModels.MainViewModel.<get_RunWorkflowCommand>b__73_0(Object param)
at UiPath.Workflow.RelayCommand.Execute(Object parameter)

@badita
@aksh1yadav

1 Like