No option in studio to publish packages directly to top level modern folders in orchestrator

hey Guys,

when i try to publish packages to orchestrator, i don’t see any option to publish package directly to modern folder feed.
I can only see 2 options - ‘tenant package feed’ and ‘Custom’.

Shouldn’t there be an option to directly publish to top level folders without first saving it in local and then uploading manually at folder level??

Is this how it is supposed to be after modern folders?
Or I am missing something here?

Please suggest.

Hi @sonaliaggarwal47,
If everything is configured well then you should be able to choose folder at the bottom before publishing:
image

Hi Pawel,

Thank you for your response.

I am able to locate all the modern folders created by following what you have shared.

However, I have further question to it:

  • After selecting which folder I want to publish package to, which option under publish dialog box we should select?

  • Here, I don’t want to select ‘tenant package feed’ as this will publish on tenant level rather I want to publish it to ‘Folder packages’ section that gets enabled under modern folder ‘Automations’

  • So only option left is ‘Custom’. How can I make us of this to publish to orchestrator. Is there a way to do that using Custom?

Please suggest.

The default option is always “tenant package feed”. This is just first step which allows you to choose further to which folder you want to attach the package. After publishing you need to log into Orchestrator and under selected folder you need to add process based on this package.

The custom option is only for situation where you don’t want to use Orchestrator. By this you can publish the package locally on your computer and run it using Assistant.

Hi Pawel,

when ‘tenant package feed’ is used, it automatically gets published to packages folder at tenant level.

And it doesn’t show up in ‘Folder Packages’ option at folder level shown below. I am looking to publish project to this folder packages directly not the tenant package feed.

image

Are on Community Cloud Orchestrator or on your custom On-Prem one?

Hey Pawel,
Its on-prem…

I have finally resolved it. To be able to see modern folders feed under Publish option, we need to make sure user that we have used to login to machine/studio have access to modern folders.
Plus in studio, right before the drop down (you shared in your response), there is another drop down from which we need to select ‘refresh’. it refreshes all the resources and make sure they are available in publish options.

image

Thank you so much for your continued support :slight_smile: :slight_smile:
Looking forward to resolve many more such issues by working together!

1 Like

I’m very happy that you figured out it! :slight_smile:
I totally forgot to ask you about access to folder for users.

Thank you very much for sharing the solution. It will really help the others with similar issue :slight_smile:

Yeah.

Though I had all access in place to folders, template etc but I was not able to see feed options for modern folders under Publish despite multiple restarts of studio.

Only thing missing was an explicit ‘refresh’. So this is also a learning here for me, just restarting studio doesn’t refresh resources always, for this to work, sometimes it has to be done explicitly.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.