No ML Skill available error in ML skill activity for Robot and Endpoint both mode

Hi guys,

I have a ML skill available in AI center for which “Make ML Skill Public” and “Enable Auto Update” options are checked, however when using ML Skill activity of package UiPath.MLServices, it shows no ML skill available.

image

Please assist me here.

Hi @Aakash_Singh_Rawat

Can you please check whether the referred ML is available or not? Click on the ML Skill & check for this option.

image

If you still face the issue, please share the error message that you are getting, so that we can analyze the situation.

Edit: Since the ML Skill is available, you are supposed to use Machine Learning Extractor in order to access the skill from the AI Center.

Hope this helps,
Best Regards.

Yes, it’s available… added the screenshots for reference.

1 Like

My requirement is to extract data from pdfs for which I have trained/created a MLSkill in AI center, how to do so with ML extractor in UiPath as it’s used with Data extraction scope.
As far I know using ML Skill activity I can provide pdf text as input and get json response accordingly.

@Aakash_Singh_Rawat

Are you labeling the data, exporting the data set & training the pipeline in order to deploy the skill?

Best Regards.

I’m not using Pipeline concept (may be I’m not aware how to apply with my case).
I have labeled data and exported it and create a ML skill, thats it.
I want to use that Skill in Studio for test PDFs.

Hi @Aakash_Singh_Rawat ,

Could you check to which tenant or account you are connected to and if it is the same account in Studio ?

Yeah, it’s the same account.

@Aakash_Singh_Rawat ,

Could you confirm the accounts again and maybe provide screenshots here of the name in the Assistant and the Users Name in Users list in Cloud ?

image

image

Let me know what else you need.

@Aakash_Singh_Rawat ,

I have missed out on some of the points already mentioned above.

As you are using the Document Understanding Models, the input and Outputs are not as same as the one present in UiPath Language Analysis models.

I believe all of the document understanding models, not only uses the data but also the area/region of the found data-points in the documents for it to understand and train or retrieve the extraction values. Hence, the input Description of the ML Packages itself mentioned we would need to use Machine Learning Extractor activity as already mentioned by @arjunshenoy .

1 Like

Hi Akash,

As you have published the ML skill as Public, could you try changing the connection to endpoint and paste the ML skill -Public endpoint on the required field in the Activity.
image

Also Please note to use the required input type based on the ML Model being used as mentioned by @supermanPunch

Cheers!

I have tried this too, I’m getting a same error in error json

“code”: “BadRequest”,
“message”: “ML Skill unavailable”,

I’m providing input first in test skill window:
{“data”:“Avisen gælder fra mandag den 22. maj til og med søndag den 4. juni 2023”}

I am using ML Skill activity to test the Invoice skill, but getting the same error. What can be the reason here?