No longer able to import custom namespace


#1

So I built a test activity library based on sample code I found in various locations:

using GmailSend;
using System.Activities.Presentation.Metadata;

namespace Our_Custom_Activities
{
public class MailClass
{

    public string GetMessage()
    {
        return "Let's send a mail with UiPath!";
    }

    public void SendMailWithUiPath(string username,
            string password, 
            string subject, 
            string message,
            string[] to,
            string[] cc)
    {
        gmail gmail = new gmail();
        gmail.auth(username,password);
        gmail.Subject = subject;
        gmail.Message = message;
        foreach(string t in to){
            gmail.To = t;
        }
        foreach(string c in cc){
            gmail.Cc = c;
        }
        gmail.send();
    }

}

// Declare dummy register metadata class to force UiPath to load this assembly
public class RegisterMetadata : IRegisterMetadata
{
    public void Register()
    {

    }
}

}

I built this, Nugetted it, placed it in Packages, installed via Manage Packages, went to Import and sure 'nuff, there’s namespace ‘Our_Custom_Activities’!

Wonderful. So I built a sample workflow exercising the MailClass in various ways (via Invoke Method, via function calls, etc.) All went swimmingly.

Then I tried to extend the library by adding two small additional classes. Rebuilt, updated the NuPkg, uninstalled & reinstalled. At first, the new classes simply did not appear in the namespace in UiPath. Then, eventually, the namespace itself disappeared and no matter what I do I don’t seem to be able to get it back. I backed out the changes I made and rebuilt. Nothing. Changed the name of the namespace. Nothing. Switched back and forth between Debug and Release builds. Nothing.

Note that each time, the package appears fine in Package Manager. But no matter what I’ve tried, UiPath refuses to recognize the namespace.

Any suggestions?

Thanks.

ddk