No issue in debug but execution fail with runtime error

Hi there,

I am trying to log into a java-based application online with a userid and password. When I run my process in debug it work perfectly. When I execute it, it fails with the following error: Error HRESULT E_FAIL has been returned from a call to a COM component. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.
at UiPath.UiNodeClass.get_visibility()
at UiPath.Core.UiElement.IsVisible()

The username field is not filled in for some reason.

This is what my activity looks like.

It was working one day and the next not at all…no idea why!

Any input will be appreciated.

Kindest regards,

1 Like

Try giving a delay before that activity and use retry activity to try it again @memrevh

That will try again and will work in any one of the try .

1 Like

No worries
—enable the property simulate type in the property Panel
—in Target property select wait for ready property as Complete
—and in delaybetweenkeys mention as 1000 that is one second per character
—and finally in the delaybefore property mention as 2000
—make sure that java extension is installed if it’s a java application
—and if it’s inside any window make sure that it’s used inside a attach window activity as well

That’s all you are done

This would work for sure
Cheers @memrevh

Hi @Palaniyappan,

Thank you so much for the advice - so much to learn!!

I did everything you mentioned above but still received this error (see properties also on the right):

1 Like

you were almost done
i hope the reson is the application is not taking SIMULATE TYPE property instead enable SENDWINDOWMESSAGE property and try once

Cheers @memrevh


It worked!!! Thank you so very much!!!

1 Like

Cheers @memrevh

Hi @Palaniyappan,

My robot now scrambles my username? The input is correct “W7109145” but when it types it out in the field on the screen is jumbles it up. Why is that?

Don’t worry - I removed the ‘Click before Typing’ and it is working now. Thank you!

1 Like

Cheers @memrevh

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.