No Heartbeat from Robots after 2018.2.6 update

We are using Enterprise licenses and I just update all of our bot VMs and Orchestrator to 2018.2.6.

None of the bots are sending a heartbeat after their jobs are completed. While sitting idle, their heartbeat stops, but if a job is started, their status immediately updates and there are no errors.



How can we solve this issue? Is this a installation error on my part or is this a bug with the 2018.2.6 update?

Can you please send us the Event viewer logs from both Robot machine and Orchestrator?

OK, where should I send the logs?

You can attach a zip file, here (5.9 KB) (6.8 KB)

Logs attached. Thanks

You can also open a zendesk ticket so we can investigate? Its our support portal.

This same thing happened to us after an update of orchestrator.

When the robot was attached the orchestrator would receive the first heartbeat, but no more. It would show to be unresponsive after the first heartbeat.

We eventually rolled back the DB and Orchestrator code and tried again. However, before the second upgrade attempt we applied the index to the logs table (as we have over 1 million rows) rather than having the DataBase migration tool do it. After this upgrade attempt the robots seemed to be responding normally.

Hopefully this helps.


Very helpful, thanks. Will keep this in mind next time we have this problem. (Problem was solved when I last looked, but not sure who fixed it or how).