No error but GetTransactionData is not incrementing

Hi, I’m working on one of the assignments where I’m trying to get the SHA hash for the items on the ACME website. I’m in the ACME website workflow and I’m having a problem getting my transaction numbers to increment. I have write lines throughout this workflow and they repeatedly return the same item. Is anyone able to help with this? Here is a screenshot of my my arguments going into the workflow:

The variables on that page:

The arguments on that page:

Then, in that workflow, here are my steps:

And continuing with my steps:

it should be 1 by default if im not wrong and dont worry about the increment. It happens by itself in the SetTransactionStatus.xml


After 1 transaction is processed what does the log say?

1 Like

Still in a loop but with a different WIID.

I’ve removed three activities from SetTransactionStatus are good from the instructions:
Remove the three SetTransactionStatus activities from the SetTransactionStatus
workflow as we are not using the transaction functionality provided by
Orchestrator.

not really . did you delete the whole thing?
Actually its just the queue activity Set Transaction Status the flow will be as-is

Can you share or show your SetTransactionStatus .xaml?

1 Like

SetTransactionStatus.xaml (52.8 KB)

I think I deleted the three activities related to it and I don’t believe I am calling/invoking it anywhere, I thought that’s what the instructions meant by deleting the activities. Do I need to invoke this xaml somewhere?

No you do not need to invoke it explicitly as its already invoked just verify once if its there.
Its in Process Transaction, finally block

Below which increments your number in SetTransactionStatus :
image

I didn’t have the Invoke SetTransactionStatus workflow activity in the Finally block of Process Transaction so I added it:

I ran it and the same loop is occurring.

please share you main.xaml i think its not correct if you are using the reframework

Here:
Main.xaml (56.7 KB)

I tried to complete the rest of the program too so hopefully once this is resolved it should run but we’ll see :slight_smile:

Need you whole project :slight_smile: can you IM it to me?

1 Like

Ok the next part that you need to do is.
After you have added the SetTransactionStatus, click on import arguments > ok
then click on edit arguments and then do the below mappings (ignore the types just the values is what you need to put)

After this it would increment

1 Like

As above, I imported arguments to the Invoke SetTransactionStatus workflow which is in the finally block of the Process Transaction state. I’m still getting the loop. Here is my screenshot:

I’m not sure how to proceed. The output is the same as before

hey i had to debug through your code to understand the issue.
First the default value you have set you can start with 0 and then let it take 0 to n
This default you have to only set in the main part and not inside the GetTransactionData
Below is not required:

Also you SetTransactionStatus was not correct and i have fixed that as well and now it working as expected.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.