No auto-screenshot is being set after targeting an activity - Studio 2018.1.1

studio
screenshots

#1

I’m creating a workflow in UiPath Studio 2018.1.1, and no auto-screenshot is being set when I target an activity. It just keeps saying “Set an informative screenshot”, and stays blank. This is not the screenshot activity, but the studio feature that takes a little screenshot to help illustrate your code.

This is for any activity, and not just on the client’s webpages. I’ve tried setting them manually, with no luck.
I checked in the screenshots folder, but it was empty, so they’re not being created at all.

This is having no affect on the functionality of the program, just it’s documentation and appearance. I was hoping to solve it if not for my sake, then for whatever poor sap after me has to maintain my code.

Development is taking place on a VM where UiPath studio is located.
I’m not sure if relevant, but the windows regular “PrintScrn” button on the keyboard works just fine, but the snipping tool on the VM doesn’t allow me to target a specific portion of the screen, just takes a whole screenshot.

Could it be a VM setup issue - some sort of policy blocking Studio from taking an image of the screen?
Any help would be appreciated, thanks!


#2

I have the same issue on 2018.1.2. It works fine on desktop PC, but not working in VM environment.

I checked there is a .screenshot folder, just the Studio is not able to generate the screenshots.


#3

Can you please try to create a project in a custom folder (not the default one …/Documents/UiPath) ? Maybe it’s about permissions on the VM?

Let me know if the screenshots are created.


#4

Hi Ovi,

Thanks for the feedback. I’ve tried different folders and still doesn’t work. I’ve given the user full access to the folder. Not sure what is missing.

Thanks,
Tim


#5

@Gabriel_Tatu do you think there could be another thing Tim can try to make this work? Would you please look into it? Thanks!


#6

HI @Gabriel_Tatu Did you find a solution as to why the informative screenshots are not appearing. We are having the same issue.

Our PC’s are locked down so that they cannot write to the C: drive but our workflows are saved to the D: drive so the screen shots should be saved there unless there is some intermediate step which requires a temporary saving to the C; drive?

Can you let us know what may stop informative screenshots within activities from occurring.

many thanks,

Clark


#7

Just to clarify the message inside the activities remains ‘Take informative screenshot’ even if you try using the ‘Set informative screenshot’ functionality after you have set up the activity.