Newtosoft duplicate dependency

Hello everyone, how’s it going?

I followed the old topic in this forum. But I can’t fix the error

When I’m running the robot by command line I’m getting the json newtosoft error. In the .nuget folder has 8 and 10 versions. even removing one of the versions the UiPath at the time of running is downloading it again. this only happens when I’m running by command line through whats studio the error does not happen anyone knows tell me how can i solve this problem?

You know I had this same issue, where I was receiving errors related to this version on Robot machines.
Check the activity package here:

I believe it will keep reappearing in the nuget folder if it is installed. If version 10 is the problem, you can update that to version 8 maybe.

I’m wondering if this will solve the issue. Let me know.

Regards.

1 Like

@ClaytonM thanks for reply. I did what you sugested, but i still receive same error message:

Method ‘Newtonsoft.Json.Linq.JToken get_Item(System.String)’ declared on type ‘Newtonsoft.Json.Linq.JObject’ cannot be called with instance of type ‘Newtonsoft.Json.Linq.JObject’.

Did you receive this still after deleting the duplicate Newtonsoft folder from your Temp folder ("%localappdata%\Temp\nuget") before publishing the project and/or on the machine that is running it?

Thanks for the answer. I discovered that publishing the project did not happen. That solved my problem.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.